Home AMX User Forum AMX Design Tools

Multi-Button Edit Goofiness

sonnysonny Junior MemberPosts: 208
This is a strange one. I have a project I've taken over with no source code left behind. So I'm re-writing the processor code. I'm going to keep the TP graphics, for now, but decided to modify all of the button codes to fit my standards. I upload the panel files and start to edit. I can edit individual buttons with no problem, however, when I select multiple buttons I get some goofy behavior.

For example, if I select several buttons and try to update the address code, TPD4 locks up and requires a Task Manager kill. Interestingly, the data in the port and code fields that are common to the buttons also disappear upon selection. If I select multiple buttons that have the same channel code (different ports), the channel code in the property window changes to something in setup, i.e. Panel Master Volume Up. I can't edit the field, but TPD4 doesn't lock up in this case.

Now, I also tried doing a Power Assign, which interestingly enough, seemed to clean the data up enough, no problems with multi-edit after that.

After talking to tech support, I tried creating a new panel and copy/paste in the screens, but no luck. Copy/paste buttons, save as different panel type, etc. don't help either. I tried other panels I've developed in the past, but the edits all work as expected. Doesn't do it on every page.

Any thoughts? Maybe a corrupt image? It would seem like editing and saving would clean up any file corruption.

Comments

  • DHawthorneDHawthorne Old Timer Posts: 4,584
    I've had corrupted panel files cause weird behavior, but it's extremely rare. There is a function in TPD4 that will refresh the channel data (Panel | Verify Function Maps) that will sometimes clear things up, but not always. If not, and the power assign is working, I'd do that to clear the bad ones.
Sign In or Register to comment.