Home AMXForums Archive Threads AMX Applications and Solutions

TPDesign4 doesnt startup on my Windows 7 PC

It used to work! but now when I try to open TPdesign4 its looks like a program is about to start (spinny circle thing), and then nothing! have tried reinstalling, reinstalling in compatibility mode. Any help much obliged?

Comments

  • BigsquatchBigsquatch Junior Member Posts: 216
    Did you try "run as administrator?"
  • derekmalonederekmalone Junior Member Posts: 11
    YES

    yes tried admin no luck
  • tdicksontdickson Junior Member Posts: 3
    I have the same problem. Using windows 7 32-bit SP1 on Dell Lattitude E5510 3GB memory. Event Viewer Just shows :

    Faulting application name: TPDesign4.exe, version: 3.0.0.634, time stamp: 0x4c76de1b
    Faulting module name: TPDesign4.exe, version: 3.0.0.634, time stamp: 0x4c76de1b
    Exception code: 0xc0000005
    Fault offset: 0x00166fea
    Faulting process id: 0x5e4
    Faulting application start time: 0x01cce7356f83e1a0
    Faulting application path: C:\Program Files\AMX Control Disc\TPDesign4\TPDesign4.exe
    Faulting module path: C:\Program Files\AMX Control Disc\TPDesign4\TPDesign4.exe
    Report Id: ad7a4720-5328-11e1-939b-782bcbdfd396
  • ColinColin Junior Member Posts: 51
    Win7 64 bit

    I am successfully running all AMX apps on a Win7 64 bit machine - just installed and they ran, maybe uninstall and try again - sorry no magic answer
  • champchamp Junior Member Posts: 261
    When all else fails i suggest deleting your current TP Design 4 installer and downloading it again then uninstall TPD4, search and delete any references to TP Design from the registry, reboot and reinstall. Make sure you select run as admin when installing.

    If that fails try installing into a different folder and make sure the shortcut is pointing at the right file.
  • tdicksontdickson Junior Member Posts: 3
    thanks for the response. I did as suggested - uninstall, remove any reference to tp4 or tpdesign from registry, rebooted, install newly downloaded copy of 3.2.661, installed into a different directory, rebooted, tried running as-is (no-admin), then as admin, then as winxp sp3 (no-admin), then as winxp3 as admin.
    all gave the same result i pasted earlier.

    any other help is greatly appreciated. Studio runs fine.
  • champchamp Junior Member Posts: 261
    I'm sorry to hear you have spent so much time on this issue.

    My next guess is that there is a corrupt dll that is not being removed or overwritten on reinstall but i would not mess with deleting dll's unless i was instructed by AMX support.

    More guesses...
    Maybe your anti virus program is messing with TPD4
    Maybe it's related to the graphics card or driver
    If you are installing off/to a network drive or synchronised folder, or the default project folder is a network/synchronised folder then try not using it.
    Try a different version of TPD4
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    I would amplify the anti-virus/firewall comment. Turn all that stuff off, (windows firewall and defender), uninstall old stuff, reinstall, launch, then turn it all back on. Some of the dll files might not get stored in the expected folder. That's one thing about Windows and their software developers that drives me crazy. You're supposed to always put dll files in the same folder as everyone else. (unless you don't want to)

    Sometimes permissions get goofed up when the installer tries to make a new folder but the OS doesn't report the error back to the running process. So, the installer happily moves on even though the file it just installed cannot be accesed when the program tries to run.

    Stoopid computers... :/
  • tdicksontdickson Junior Member Posts: 3
    thanks again for the feedback. I tried the uninstall/reinstall as before with the addition of the anti-virus and firewall stuff turned off, but still have the same results. Does anybody have a list of files i can look at to make sure the uninstall actually takes everything off and the installer actually puts everything where it is supposed to go?
  • AuserAuser Junior Member Posts: 506
    The easiest solution may be to install Windows XP Mode and run it under that. [ur]http://www.microsoft.com/windows/virtual-pc/download.aspx[/url]

    I'm suspecting that there's a system file version dependency issue with msvcrt.dll or other file on your machine.
  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,550
    The files are in many locations, and hard to identify, so I doubt a list is coming, and doubt its completeness if it does.

    For what it's worth, I installed over my old TPD4 on Win7/64 without incident.

    I moved the SETUP out of the ZIP, right clicked on it and did RUN AS ADMINISTRATOR, and all was good.
Sign In or Register to comment.