Home AMXForums Archive Threads AMX Hardware AutoPatch Forum

Touch Panel Not Responding

tspoetspoe Junior MemberPosts: 32
Hello,
I'm not sure if this is the right forum but I'm not really sure where my problem lies. I am trying to troubleshoot why the touch panel is no longer creating ties based on which input/outputs are selected. It was working last week and the only changes I've made to the code was adding the ONLINE event for the projector and Tandberg C40 camera and the including the duet modules. I have since backed out those changes and still not working. Hoping someone can tell me what else I can do to troubleshoot the problem. I can make ties from the control panel of the switch. When making assignments using the touch panel I can see in the Notifications window the command being sent (CI2O5) and the command being translated (CL1I2O5T) but no action. When I try to make ties via 'Control a Device' using the same command, nothing happens but I can see the translation in the Notifications window.

Can anyone tell me what other steps I can try to troubleshoot the problem?
Thank you,
T

Comments

  • HARMAN_ChrisHARMAN_Chris Harman Professional University Posts: 321
    To be clear, you
    1) Had a working system
    2) Added a duet module for a Tandberg C-40
    3) Added a duet module for a Projector
    >>Lost control of your video switch
    4) Undid the changes adding the C-40 and projector
    >>Still no control of your video switch
    5) When pressing the original buttons on the touch panel, you are able to view strings being sent out to the video switch using Netlinx Studio > Notifications. The strings go out, but the expected switching action does not occur.
    6) When using Netlinx Studio > Control a Device, the strings go out, but the expected switching action does not occur.

    Correct? Ultimately, if the button pushes on the panel are triggering the output string to the device from code, the problem is not your touch panel. It would appear that in your changes (code, wiring, or both), something in the environment between the NI Master and the video switch has changed.

    In notifications, what port are the strings to the switcher going out on?
    Do you see the RX strings coming back from the switcher when you send a string out?
    Do any RS232 devices work in the system or is it just the video switch?
    In your device definitions, what is the current declaration for the physical address of your video switch?
    Does that match the port the strings are going out on?
    When it is not working, what is the baud rate of the port you are connected to?
    Does that match what the device is set to?
    In your module definition for the video switch, do you have a physical device and a virtual device - or the virtual device twice?
    Do you still have the new devices defined or were they completely removed?
    Does one of those devices share the same virtual device number as your switch?
    Does one of those devices share the same physical device number as your switch?
    Was there any wiring done to support the new codec and/or projector?
    If so, is there a chance that the video switch wire has beenotherwise/disturbed/or otherwise changed?
  • tspoetspoe Junior Member Posts: 32
    Hi Chris!
    Everything checked out but we did recently change (re-terminate) the RS-232 cable from the controller to the AMX Switch. We tried 3 different cables and that didn't appear to be the problem. We started to wonder if the port was bad, so we moved the switch to a different port on the controller, changed the D:P:S in the code, reloaded the code and it worked! We moved the Switch back to the original port and it still worked! So it doesn't appear to be the port. We've been having problems since then tho...the program seems to lock up on us (3 times so far today) and the only way to get it to work again is to move the Switch to a different port (which works) then move it back to the original port (and it works). Have you ever experienced this before? Is it a sign the port is going bad?
    Thank you!!!
    T
Sign In or Register to comment.