Home AMX User Forum AMXForums Archive Threads AMX Hardware
Options

NI-4100 losing network connection

Has anyone run in to any issues with an NI-4100 dropping network connectivity? We have tried using a static ip, static dhcp using the MAC ID, and just dhcp.

The controller will come up online, and I can stay connected anywhere from 3min to 20 min, then it drops off the network.

Also have obviously swapped cables and ports on the switch. The NI is located in the same closet as the network switch so it is maybe a 10' cable run, no bad drops or anything in between. None of the touch panels seem to be dropping off and neither are any of the computers connected to the same switch.

Any ideas from anyone? Just wondering if I am missing something really simple. Lastly, this is a brand new NI-4100 purchased within the last few months.

Comments

  • Options
    ericmedleyericmedley Posts: 4,177
    For the longest time I had issues with NIs and cheaper Linksys model Routers/Switches. I never really figured it out except to not allow the client to choose equipment not approved for use with NIs. It was usually not an issue since our clients weren't too price conscience when it came to networking gear.

    The same thing was ture on these routers/switches. Everything else (including AMX touch panels and whatnot) would stay online without a hitch.

    I tried all kinds of tweaking on the settings in terminal to no avail. So, the solution was to just try another make/model of networking gear or make the AMX master reboot when it looses connection to the outside world.


    Niether of these is a good solution, I know. But, that's what I had to do.
  • Options
    John NagyJohn Nagy Posts: 1,736
    The Linksys issue was well discussed here years ago. It was traced to an auto-negotiation issue on ethernet mode. AUTO is what everything normally uses, but Linksys routers can't agree on a rate and mode with a NetLinx. Setting the NetLinx manually to 10 Half Duplex was said to resolve the issue... while this seriously reduces the IP throughput on the NetLinx, in real life it couldn't be detected in performance.

    This was supposedly all cured by newer Linksys and newer NetLinx firmware. But that's where we come in... reality is made up of corner cases, and we live in reality.

    Knowing what happened before and what got around it may help you now. Good luck...
  • Options
    AuserAuser Posts: 506
    I have seen this behaviour in two separate and very different circumstances:

    - When no gateway was specified in the IP settings. May have been resolved in more recent formware.
    - When a dodgy Netlinx module from the AMX website for a Polycom VC codec was included in a program.

    Both were ages ago, but the Netlinx module one tends to suggest that a runaway program could take down Ethernet access to a master. Are you able to connect via the console and check the error log when in the fault state?
Sign In or Register to comment.