Home AMX User Forum AMXForums Archive Threads AMX Hardware

NI-700 no boot

I think the memory has become corrupt or the unit has failed, but I wanted to check here first:

NI-700 no boot condition. Status, Output and Input lights all lit solid = Signifies system boot.

Unit is hanging in this status. No network connectivity or Terminal connectivity. Tried turning on the PRD mode and same result.

Normally in this case with a NI-XXX I would swap the CF card, but it appears that there is not CF card on this unit.

Any other suggestions?


  • Options
    ericmedleyericmedley Posts: 4,177
    Time to send it in to AMX.
  • Options
    jabramsonjabramson Posts: 106
    Do you happen to know the approximate cost for repair? Trying to decide between repair or replace.
  • Options
    ericmedleyericmedley Posts: 4,177
    jabramson wrote: »
    Do you happen to know the approximate cost for repair? Trying to decide between repair or replace.

    I don't know what your cot would be. You should check what your dealer agreement is. Repair can tell you an estimate, I'm sure it'll be the standard bench fee charge.
  • Options
    mushmush Posts: 287
    jabramson wrote: »
    Do you happen to know the approximate cost for repair? Trying to decide between repair or replace.

    Do you still have this box or have you returned it?
    I may have a fix for you.
  • Options
    I still have it
  • Options
    mushmush Posts: 287
    jabramson wrote: »
    I still have it

    Okay, first thing is to make yourself a serial cable to connect to the 'Debug' port inside the NI.

    Find the debug port on the main board and use pins 2, 3 & 5 with a crossover.
    115200, 8, N, 1
    I made my cable using an old computer CD audio cable. The flat black 4 pin connector fits perfectly, just offset it by one pin so that the earth lead is on pin 5 of the board connector.

    Once you've made your cable plug it in and run up your preferred terminal emulator.
    Then boot your NI.

    You should see a stream of info coming through. Look for any errors.
    This is the error that I had.
    Error: invalid inet address in boot field "".
    Can't load boot file!!
    If you had the same error then you need to halt the boot process and fix the boot parameters.
    You will see a message shortly after you power up the NI that says "Press any key to stop auto-boot...".
    If you press (?) you will see a list of commands.
    I had to use (c) to change the boot parameters and then (g) to change the gateway address.
    Once you've corrected any errors you can press (^D) to exit and then (@) to boot the master.

    If you find a different error then you will have to do your own research.
    I found everything I needed in about 5 minutes.

    Good luck!
    Let us know how you go.
  • Options
    I was able to connect into the debug port and get to the VxWorks console.

    This is the error I'm getting
    [VxWorks Boot]: @
    boot device          : doc
    unit number          : 0
    processor number     : 0
    host name            : host
    file name            : vxWorks
    inet on ethernet (e) :
    host inet (h)        :
    gateway inet (g)     :
    user (u)             : gimli
    ftp password (pw)    : gimli
    flags (f)            : 0x8
    target name (tn)     : AMX_Atrium
    other (o)            : emac
    Attaching to TFFS... tffsDevCreate failed.
    usrTffsConfig failed.
    Error loading file: errno = 0x0.
    [VxWorks Boot]:

    I have another working NI700 and I copied all the boot parameters to the non working unit and I'm getting the same result. Tried my google-fu but couldn't come up with anything solid. All the commands that are suggested appear to not be supported on our little boxes.

    Any ideas on what to try next?
  • Options
    gsmithgsmith Posts: 59
    TFFS is the VxWorks flash file system and appears to be corrupted to the point that it can't be accessed. There's nothing more that I can think of for you to try on your own.
  • Options
    That is what I was afraid of. Thanks for your help.
Sign In or Register to comment.