Home AMX User Forum AMX Technical Discussion

SMTP_SENT Stopped working for no apparent reason

I've got a NX-2200 Master Firmware 1.6.179, I have a program that has been running in some form for years. It was previously running on a NI-4000 just fine. About a month ago It stopped sending me emails. I have a section of the program that sends me a text every morning at sunrise with the sunrise sunset and moon phase. It is also supposed to send me an email when one of my WiFi temperature sensors drop offline. This code has literally been working for years. I get an authentication error every time. (error 4) I though that Gmail may have changed things, but it seems not. I tried to log on another SMTP server (outlook.com) and it would not use that one either!
Here is the setup code:

dvMAIL_SERVICE = 0:3:0


and the send code is:

Any help would be appreciated, I thought that AMX had the e-mail thing all worked out.


  • HARMAN_ChrisHARMAN_Chris Harman Integrated Technologies Group (ITG) Posts: 417

    Is the time of day correct on your controller? I'm just guessing, but we have seen it be a factor in IP comms.

  • Jim JohnsonJim Johnson Junior Member Posts: 27

    Yup, That's all good. I have it Sync'd to NIST. The last few errors have been error 5. It sync's time fine, I'm talking IP to a DSP, and I have 7 IP servers setup for my IOT boards to connect to, all those are rock solid.
    I even tried to move back to the NI-4100 (sorry I had it wrong in the earlier post). I'm wondering if Gmail and outlook moves to SSL and dropped TLS? their FAQ's say TLS, But??? Tomorrow I may load a program that is just an SMTP setup and send just to rule out other code.

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 587

    TLS is updated and more secure SSL - transition was after SSL 3.0. As of 2011 any backward compatibility from TLS to SSL was removed - because security. All versions of SSL have been fully deprecated and TLS versions 1.0 and 1.1 are on the way to being fully deprecated.

    A quick look seems to indicate that Gmail is specifying an Elliptical Curve cipher exclusively - and that could be the issue. Master firmware 1.6.201 fully enables EC Cipher support in Duet - NetLinx TLS client has supported EC ciphers for some time. If the SMTP_MAIL client is reliant on the Duet libraries than the f/w update should resolve the issue - if not you should escalate this through Tech Support.

  • Jim JohnsonJim Johnson Junior Member Posts: 27

    So an update, I got it to work with Google SMTP servers after creating several new App passwords. for some reason the old app password stopped working, and creating new ones is a bit hit and miss?? I still could not send to the outlook SMTP servers, maybe they require SSL??

    Anyway Thanks for your support!...Jim...

Sign In or Register to comment.