Home AMX User Forum AMX General Discussion

Yet another Apex 6100 rs232 thread

wberriel1wberriel1 Junior MemberPosts: 11
So I've spoken to Apex, and my security installer, and I'm having a hell of a time getting a rs232connection between my Apex 6100 panel and either a nxi-3100 or my computer using both the Apex Demo software or hyperterminal. I'm hoping someone here can give me some hints. Basically I have the rj45 to db9 connection wired exactly as described in both the Apex and AMX documentation, I'm using the rs232 board on the Apex, a straight through ethernet cable (tried both homemade and premade). The connection is running at 1200 baud, 8, n 1, no flow control. The security panel is set with address 0155 equal to 009 and all the zones have 16 added to them.

So it doesn't work with the netlinx controller. No problem, I'll test with hyperterminal and a serial port on my laptop. The hyperterminal is configured as described above (which are the settings the Apex tech support gave me). When I connect with hyperterminal it gives me a character echo, or the same character echoed twice if I turn on local character echo as the tech told me. However it does not give me any responses from the security panel. For example if I type "08as0064" which is I believe the armed status request, I get nothing back.

So the question is, did any of you guys (or girls) who got this working have to do anything strange? Or is there something I'm missing?

Thanks.

Comments

  • banobano Senior Member Posts: 165
    These docs may help you troubleshoot your problem.

    Good Luck!
  • NMarkRobertsNMarkRoberts Junior Member Posts: 455
    The character echo could just mean miswiring in your cable or indeed in the Apex.
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    We have a bunch of Destiny6100s in our systems.

    Until the last two systems, we had a 100% success rate with them.

    However, the last two systems (one is still a problem) gave us problems with connection.

    As you probably know, you have to spend a lot of time with both AMX and Honeywell tech support listening to them say it's not their fault call the other guy...

    In the first case we ended up (after four Honeywell calls) finding out that the Destiny 6100's RS-232 daughter board was defective. It was indeed communicating from the Apex to the AMX systesm. However, AMX to Destiny6100 was not working. We used a volt meter to check several things on the Destiny and determined that the daughter board was not working for some reason. We replaced the daughter board and all was well.

    The 2nd case (the one still out there) is a bit more complex. I'm using an older AXB-232++ box to connect to the destiny. I am getting reasonable data to and from the Destiny but the system is not responsive to any commands. Also, the AMX module is receiving data from the AMX box, but is doing nothing with it.

    The module is actually pretty old and time tested. And, as I said, we have 8 other systems that work great.

    You might check the daughter board or swap it out if you have a spare and see what happens.
  • wberriel1wberriel1 Junior Member Posts: 11
    The character echo could just mean miswiring in your cable or indeed in the Apex.

    So by default, it does not echo characters, do you know?

    thanks.
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    wberriel1 wrote:
    So by default, it does not echo characters, do you know?

    thanks.

    I just tried it on a working system and it does not echo back.

    However, I just looked in my notes, and in the failed Destiny 6100 RS-232 daughter boards in my example above, that was one of the symptons.
  • wberriel1wberriel1 Junior Member Posts: 11
    So just to add another aspect here, while the daughter board is plugged into the destiny 6100, there is continuity between the tx and rx pins. Which is why I'm getting character echo. However, it gets wierder, as the character echo does not occur at bauds rates of 9600 or above, but if I use a serial loopback cable, the character echo works at any speed.

    I guess I gotta call honeywell about a failed board here.
Sign In or Register to comment.