NI-3100 Connectivity issues

John PaulJohn Paul Junior MemberPosts: 143
I have an NI 3100, the details are given below. I am able to connect via serial, telnet and ping the controller . But i am not able to connect via Netlinx Studio. I am using the latest version of Netlinx Studio. Anybody faced the same issue. I tried connecting to controller via cross cable but even that is not working.

Device Name: NI Master
Device Number: 0
Port Count: 1
FWID: 380
OID 1: vxWorks Image v3.41.422
OID 2: BootROM v3.41.422
OID 3: AXLink I/F uController v1.13.7
Manufacturer: AMX LLC
Version: v3.41.422

Comments

  • CT-DallasCT-Dallas Junior Member Posts: 157
    John,
    In your IP connection properties, do you have the "Automatically Ping the Master Controller to Ensure Availability" box checked? If so, uncheck it. I do not think I have ever been able to connect when that box is checked and it is checked by default.
  • John PaulJohn Paul Junior Member Posts: 143
    Done that

    I tried that already but no success in connecting via Netlinx Studio
  • CT-DallasCT-Dallas Junior Member Posts: 157
    John,
    Can you view the webserver page from a browser?
    Can you listen for the master and have it find it?
    What about zero config?

    In telnet, you could check for settings like SET ICSP PORT and ensure it is set to 1319

    You can also try RESET FACTORY just to rule anything weird out.

    I apologize if you have already tried some or all of these steps - just thinking of things you could try.
  • John PaulJohn Paul Junior Member Posts: 143
    Thanks , i reset to factory settings and now its connecting via netlinx studio. This was system number 8, and i had just fed the url listing of all the controllers from 1 to 7 with the new system ip and set the route mode to direct. This time i deleted all the url listing of all the systems and did it from scratch and now it stays connected.
Sign In or Register to comment.