Home dbx Installed Products

DBX 286s cuts out

I have a few 286s processors. Im experiencing an issue where the signal distorts and cuts out after approximately 15 minutes every time.. if you unplug the cable from the mic and plug it back in or change the cable it works fine. The units show an input signal but there is no output signal. I've changed mics and cables but it always cuts out after approximately 15 minutes. EVERY time.

Comments

  • HARMAN_EEldeHARMAN_EElde Posts: 701

    @cashrandya said:
    I have a few 286s processors. Im experiencing an issue where the signal distorts and cuts out after approximately 15 minutes every time.. if you unplug the cable from the mic and plug it back in or change the cable it works fine. The units show an input signal but there is no output signal. I've changed mics and cables but it always cuts out after approximately 15 minutes. EVERY time.

    I would recommend contacting tech support to setup a service case to have it sent in and looked at. There is nothing we can suggest troubleshooting wise in the field to fix. Contact is in my signature

  • Hello @HARMAN_EElde,

    I am experiencing the same issue. The unit had been sent in for repairs in March of this year. When I got it back it worked fine, then this issue started. I was in the middle of a book narration and it limped along until I was finished.

    I'm a little disappointed that the issue arose so soon after factory repair.

    What can be done?

    Thank you,
    ~Ace

  • @AceEdewards said:
    Hello @HARMAN_EElde,

    I am experiencing the same issue. The unit had been sent in for repairs in March of this year. When I got it back it worked fine, then this issue started. I was in the middle of a book narration and it limped along until I was finished.

    I'm a little disappointed that the issue arose so soon after factory repair.

    What can be done?

    Thank you,
    ~Ace

    Hello Ace. I would contact [email protected] with your original Service RA details and let them know that you already had sent it in and are still having issues after repair.

Sign In or Register to comment.