Home dbx User Forum dbx Live & Portable Products

DriveRack Venu 360 Can't load presets

I've been using my venu 360 for about a year without any problems. Today when I powered up, the outputs were all muted. I keep the screen locked so no one can accidentally mute them, so this was unexpected. I cycled the power with same result. Then cycled the power unlocking the screen in the process. Still could not unmute channels. I tried restoring 2 of my presets, and a couple of default presets. Each time after a progress bar went across the screen, the screen ends up saying "Press the wizard or config button to configure the preset". When doing from the iPad, it says presets are empty (which I know is wrong). I also tried running through the setup wizard, but it still results in the same message, and I still can't unmute any channels.

It appears to me that on power on today, It somehow lost the running configuration, and will not allow me to reconfigure. Not sure where to go from here.

Comments

  • HARMAN_EEldeHARMAN_EElde Posts: 1,133

    @jacgec said:
    I've been using my venu 360 for about a year without any problems. Today when I powered up, the outputs were all muted. I keep the screen locked so no one can accidentally mute them, so this was unexpected. I cycled the power with same result. Then cycled the power unlocking the screen in the process. Still could not unmute channels. I tried restoring 2 of my presets, and a couple of default presets. Each time after a progress bar went across the screen, the screen ends up saying "Press the wizard or config button to configure the preset". When doing from the iPad, it says presets are empty (which I know is wrong). I also tried running through the setup wizard, but it still results in the same message, and I still can't unmute any channels.

    It appears to me that on power on today, It somehow lost the running configuration, and will not allow me to reconfigure. Not sure where to go from here.

    Try to do a Factory Hard Reset first (Hold Store while Powering Up the Venu360).

    If that does not work you may need to try the Manufacturing Firmware Updater here:

    https://help.harmanpro.com/venu360-manufacturing-updater

    If you still cannot get the Venu360 back to operating order you can contact Tech Support in the signature below for Service RA options

Sign In or Register to comment.