Home DigiTech Software

Trio+ Updater error message

Tried the Trio+ Updater today and got error message message dialog box saying "Failed to check for updates". No error number or any other info. It sees the Trio fine. No problem with the internet connection. The app shows MCU version 1 and DSP version 3.1. Styles 0xF7D6. Ensemble: 0xD5C.

Any ideas?
Thanks,
Sean

Comments

  • HARMAN_EEldeHARMAN_EElde Posts: 610

    @SeanMcGrath said:
    Tried the Trio+ Updater today and got error message message dialog box saying "Failed to check for updates". No error number or any other info. It sees the Trio fine. No problem with the internet connection. The app shows MCU version 1 and DSP version 3.1. Styles 0xF7D6. Ensemble: 0xD5C.

    Any ideas?
    Thanks,
    Sean

    Not sure about the error, possibly firewall is blocking the program from looking? Nonetheless, by the information you provided that is the latest Firmware (DSP version 3.1)

  • I ran it as Administrator (Windows 10) and the "Check for updates" worked.

  • HARMAN_EEldeHARMAN_EElde Posts: 610

    @SeanMcGrath said:
    I ran it as Administrator (Windows 10) and the "Check for updates" worked.

    Excellent, perhaps your security settings on Windows 10 requires it to work that way, I have not run into that on Windows 10 with the Updater or Manager myself.

    You can right click on the icon for the program, go to Properties>Compatibility and there is a check box for Run This Program As Administrator as well so that you do not have to right click it every time.

Sign In or Register to comment.