Home DigiTech Products

My Trio+ Is Unable to Format New SD Cards

I've been using my Trio+ for around 6 months. Having finally filled up the slots on the original SD card provided with the unit, I need to start up with a new SD card.
According to the manual, I should be able to just insert a new SD card and the unit will format it to what it needs to see.
So I inserted a brand new SD card... the unit's lights flash, then all part lights remain red, indicating a bad or incompatible card. I tried a 2nd brand new SD card, same result.
But I then inserted the original SD card and the unit boots up as normal ready to go.
Is there something specific I need to do to a new SD card prior to inserting it into the TRIO+ for it to read and format correctly?

Answers

  • Try formatting on a PC with regular Fat32 and then try to insert in the Trio

  • SilvioGSilvioG Posts: 4
    edited September 14

    Great Minds @HARMAN_EElde!
    Yes, I did end up trying that yesterday, using both the 'Quick Format' and (when that failed on the Trio+) then the full format option. Still no joy on the Trio+.

    I also tried using the Trio+ Manager PC app to restore a backup of the Trio data file from my OEM SD card to one of the new PNY cards after formatting, and then the other PNY.
    (I was also surprised the Trio Manager software even recognized the PNY cards, after not functioning in the Trio+)
    Needless to say, the Trio+ still does not accept either PNY card, although the pedal still functions just fine with the OEM SanDisk SD card.

  • HARMAN_EEldeHARMAN_EElde Posts: 695
    edited September 14

    @SilvioG said:
    Great Minds @HARMAN_EElde!
    Yes, I did end up trying that yesterday, using both the 'Quick Format' and (when that failed on the Trio+) then the full format option. Still no joy on the Trio+.

    I also tried using the Trio+ Manager PC app to restore a backup of the Trio data file from my OEM SD card to one of the new PNY cards after formatting, and then the other PNY.
    (I was also surprised the Trio Manager software even recognized the PNY cards, after not functioning in the Trio+)
    Needless to say, the Trio+ still does not accept either PNY card, although the pedal still functions just fine with the OEM SanDisk SD card.

    Thanks for the follow up!

    I've only had luck with the SanDisk and Samsung brands in our Digitech pedals tbh. Might be worth picking up a couple of 8gb SanDisks on Amazon, they're cheap enough. Lemme know how it goes?

  • Yes, I had an uneasy feeling that might just be a case of brand/manufacturer.
    This morning ordered a couple of SanDisk 16GBs; 1 Edge and 1 Ultra.
    The Ultras especially are a good deal currently. If it works I'll order up a few more before they're also discontinued. lol
    Either way, I will post up how it turns out.

  • Sounds good, please do!

  • I just popped a new SanDisk 16GB card into My Trio+.
    JOY! The pedal initialized it, booted up and is now functioning as normal.
    Thank you HARMAN_EElde for your help, and especially for that key data re: SD card brands that might work best!

  • @SilvioG said:
    I just popped a new SanDisk 16GB card into My Trio+.
    JOY! The pedal initialized it, booted up and is now functioning as normal.
    Thank you HARMAN_EElde for your help, and especially for that key data re: SD card brands that might work best!

    Oh excellent news Silvio! Thanks for the follow up and you're welcome, now get to jamming!

Sign In or Register to comment.