Home DigiTech Forum DigiTech Products

Trio + Manager

Hi All
New owner of a Trio+ here. Having problems with Trio Manager software.
When I put sd card into laptop my songs dont show up on left hand side when i clickopen card`
Any help much appreciated

Best Answer

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123
    Accepted Answer

    @a1terrier said:
    Hi
    Thanks for email. reinstall worked!!
    Thanks very much for your support

    Awesome news! You're welcome!

Answers

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123

    @a1terrier said:
    Hi All
    New owner of a Trio+ here. Having problems with Trio Manager software.
    When I put sd card into laptop my songs dont show up on left hand side when i clickopen card`
    Any help much appreciated

    Is the Trio+ reading the card and parts on it just fine?

  • a1terriera1terrier Posts: 12

    Hi
    Many thanks for quick reply
    Yes the Trio + is reading the card fine it’s the Trio Manager software that isn’t
    I’m running windows 10 on a Lenovo laptop

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123

    @a1terrier said:
    Hi
    Many thanks for quick reply
    Yes the Trio + is reading the card fine it’s the Trio Manager software that isn’t
    I’m running windows 10 on a Lenovo laptop

    Does the card show up in Windows Explorer as a detected drive when you plug it in?

  • a1terriera1terrier Posts: 12

    Hi
    Thanks for reply

    Yes it does show up as a detected drive

    Just installed manager software onto another laptop with same result

    Trio manager is saying card is write protected when it’s not

    When I insert a new card it just displays previous card and it won’t clear information

    I’m running windows 10, could that be the problem?

    Thanks

    Chris

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123
    edited April 8

    @a1terrier said:
    Hi
    Thanks for reply

    Yes it does show up as a detected drive

    Just installed manager software onto another laptop with same result

    Trio manager is saying card is write protected when it’s not

    When I insert a new card it just displays previous card and it won’t clear information

    I’m running windows 10, could that be the problem?

    Thanks

    Chris

    Should not be an issue no, that's a strange one indeed. I haven't tested it on the new build yet though Windows 10 20H2. Verify your Windows build version? (click start and type in winver then hit enter)

  • a1terriera1terrier Posts: 12

    Hi
    Thanks for reply

    It says

    Version 20H2 (OS Build 19042.867)

    It is 62 bit

  • a1terriera1terrier Posts: 12

    Just to add it is very frustrating as I love my trio+ but I need the software to work

    Thanks

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123

    Unfortunately it will be some weeks that I am in front of a Trio+ to test personally but I'll see what I can find out in the meantime.

  • a1terriera1terrier Posts: 12

    Ok thanks
    It’s the same issue with the card supplied with the trio and another Sandisk I have

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123

    @a1terrier said:
    Ok thanks
    It’s the same issue with the card supplied with the trio and another Sandisk I have

    Thanks for that info!

  • a1terriera1terrier Posts: 12

    Hi
    Have you any news re trio+ manager?
    Thanks

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123

    Confirmed Trio Manager working fine on latest build Windows 10 20H2, was able to back up songs and the card

  • a1terriera1terrier Posts: 12

    Hi
    Thanks for email, just tried it again and manager software still not reading cards although songs are on card and work on Trio+
    Would a reinstall work? I have done this before but with same results.
    Thanks

  • HARMAN_EEldeHARMAN_EElde Posts: 1,123

    @a1terrier said:
    Hi
    Thanks for email, just tried it again and manager software still not reading cards although songs are on card and work on Trio+
    Would a reinstall work? I have done this before but with same results.
    Thanks

    Might be worth a shot yes. I would use this uninstaller utility:

    https://www.iobit.com/en/advanceduninstaller.php

  • a1terriera1terrier Posts: 12

    Hi
    Thanks for email. reinstall worked!!
    Thanks very much for your support

Sign In or Register to comment.