SX20 Module controlled via USB to Serial

Hello,

Has anyone used a USB to Serial cable and the AMX Module to control a Cisco SX20?
I couldn't get any comms when using USB to Serial Cable(s).. i tried 3... to any NI Serial Port

Are there any settings on the SX20 perhaps?
Any help would be great.

In the end i used IP control.

Cheers,
Ant

Comments

  • RichardHamiltonRichardHamilton Member Posts: 58
    If you are talking about the USB/Serial on the Cisco (ie, not on your computer) then you need to specifically order the Cisco USB/Serial adapter. Also, I seem to recall that some admin/security setting in the Cisco has the serial port disabled.

    If it's a fresh unit that you have setup, then security may not be the issue, but if someone else has been the admin, they may have locked the unit down.

    Also, I found that having too many conductors on the serial cable may create a hardware hand shaking flow control lock. Rebooting the controller seems to be required if that occurs. Just use a three conductor serial cable to avoid this issue.

    But yeah, go IP if possible.
  • Larry LawrenceLarry Lawrence Junior Member Posts: 8
    I recall in the past year going through the same thing with an SX-20, and an NI-4100. I don't believe the USB/Serial dongle was anything special. As the previous post indicates, I did use only a pin 2-3-5 cable. The one tidbit that stuck with me was that after much frustration I found I could only connect using COM 1 on the 4100 (so busy these days I haven't taken the time to dig to deep into that mystery, I just know the demo program that came with the module was set up that way so I went with it). The module I used is the 'Cisco_C20_Comm_dr_1_0_0' from the online device database (I see they have a much newer one).

    We always use serial to control codecs, so I do know the Cisco C and SX series always require the steps of going into the admin menu to the SerialPort section and turning LoginRequired to off (the alternative is to bake the default SerialPort login credentials into your code).

    One note, after connecting the dongle the codec requires a reboot to recognize the device (I presume like a PC, it has to load the driver but only does so when it sees the new device at startup). Other than that it's been reliable over RS232 at 38400.

    Hope this helps and best of luck.
    Larry
  • Larry LawrenceLarry Lawrence Junior Member Posts: 8
    Just a follow-up, I found the adapter we used is a SIIG USB to Serial Adapter Cable (p/n JU-CS0111-S1). http://www.siig.com/it-products/serial-parallel/serial/usb/usb-to-serial-adapter-cable.html
    I didn't recall, but was told we'd tried another generic adapter with no luck, hopefully this helps steer you towards a solution.
    LL
  • AntAnt Junior Member Posts: 54
    Thanks guys for your responses i will try and bench test the unit in the office for future deployment.

    Thanks again
Sign In or Register to comment.