Home AMX User Forum AMX Resource Management Suite Software

RMS SDK 4.3.17 is corrupted

This SDK 4.3.17 has a corruption in the CUSTOM_EVENT's CUSTOM.ENCODE string.
When you use STRING_TO_VARIABLE on this version you will get an CIpLibrary::String_To_Variable - Error -1.
Which is " -1 = Decode variable type mismatch" and that gives me the conclusion that the string in the custom_event created by the RmsNetLinxAdapter_dr4_0_0.jar is corrupt.

Use the previous SDK 4.3.12 until another release fixes this.


  • ericmedleyericmedley Posts: 4,177
    Thanks for letting us know!
  • RMSDevRMSDev Posts: 7
    Hi there Dennis,

    What is your character encoding set to? Which structure is being decoded when you see this error message?

  • tadem2ktadem2k Posts: 4
    I also get this message after upgrading to 4.3.17 when pulling scheduling information via API command, specifically when RmsEventSchedulingBookingResponse function being called.
  • RMSDevRMSDev Posts: 7
    Try executing these commands back to back when the RMS client comes online as a temporary work around until a fix is available:

  • tadem2ktadem2k Posts: 4
    This fixed it for me, thanks
  • AvargasAvargas Posts: 57
    Thanks for the info, I was mad with this thinking that the problem was any recent change in my code.
  • The SDK 4.3.17 issue which I had was an update issue (going from the previous to a newer), probably the one which RMSDev had the solution too.
    I fixed it with erasing the masters completely and start fresh.

    There is a bug when there are no bookings in current month.

    (19:28:55.731):: Command To [41001:1:1]-[?SCHEDULING.BOOKINGS.SUMMARY.DAILY-06/5/2015,2]

    Will return nothing except in the diagnostics window

    (19:28:56.117):: 2015-06-06 19:28:56,748 ERROR [Timer-0] com.amx.rms.client.netlinx.adapter.result.impl.Sch edulingBookingsSummaryDailySuccessHandlerImpl - run(): dailyCount is null

    I've got a JIRA ticket in devs on this and I've recieved a test pre update which fixes this issue.
    New version is going to be released rather soon of what I've heard.

    Also good to know is there are specific NI (4.3) and NX (4.4) releases of RMS SDK.
  • pdabrowskipdabrowski Posts: 184
    Dennis E. wrote: »
    Also good to know is there are specific NI (4.3) and NX (4.4) releases of RMS SDK.

    Don't do what I did and neglect to update Studio, I grabbed the 4.4 SDK for the NX masters and got major compile errors because I was running on an old version of NS4 that didn't play nice with the new SDK. Namely "rmsclient is not a valid module type" even when I didn't declare that jar as a module in my code.
  • ​I can report that RMS SDK NI version 4.3.23 is working find.
Sign In or Register to comment.