Home AMX Control Products

MXT1000 Setup window won't go away.

SeoulhawkSeoulhawk Junior MemberPosts: 9

Hello, I am really a novice at AMX programming. I have worked with AMX products for many years, but I don't program. So I have a few simple projects and some time so I thought I would take some old equipment off the shelf and attempt a bit of programming. I picked up an MXT1000 that was on the shelf and it was working fine with its old programming did a factory reset and ended up with the only the panel configuration setup popup window showing, and I can't make it go away. I tried to send it a program and it took, but still shows nothing but the configuration setup popup.

Any ideas on how to make it go away and start showing pages??

Thanks

Comments

  • richardhermanrichardherman not-so-junior member Posts: 286
    edited October 2020

    So if you pull power to the panel then re-apply it, when it comes back, it has a setup page showing?
    If so, maybe the (physical) button on the top edge of the panel is stuck in it's 'on' state.
    Worth checking, I guess..

    EDIT: maybe I'm assuming too much.. If you erase the user pages (from the setup) and do a factory reset, than the panel will show just a setup page. I assumed you reconfigured it and load pages onto it, but maybe not?
    What made you conclude that 'the program took'? Maybe you meant you sent a program to the controller? The layout for an AMX touchpanel is a seperate thing that needs to be uploaded seperately from the program.

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Yes, yes, and yes. I have tried power, both ways and uploaded new pages. I did see the panel accept the new pages, but it just shows the setup page.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,605

    If the panel worked before the reset, there's really only 3 likely explanations...
    1. The panel was damaged between the reset and the reload.
    2. The panel memory is corrupt - the old project working but the new one loaded in a bad section and can't start
    3. The project is defective or did not complete the load.

    Check your panel project to be sure you have a default start page that exists.
    Using STUDIO, tell the panel to display pages you know are in the project.
    Good luck.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,605
    edited October 2020

    The POWER UP PAGE is set on PROJECT PROPERTIES, you'll find that in the FILE dropdown in TPDesign. If you don't actually have the page it is set to in the project, the panel has nowhere to go and the setup page will remain.
    You can also try pushing new firmware to the panel and see if it wakes up and smells the coffee.

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Thank you, I will give that a shot.... Should have brought it home with me... I checked the Project Properties and it does have a start-up page. I will see about getting the firmware and trying that as well.

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Tried your suggestions with no luck. Could not upgrade the firmware, start-up page is correct... Such a shame it looks dead, never really used. Lost its life set on a shelf.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,605

    You don't mention whether you can direct the panel to show pages from your program or Studio. That would normally take the panel out of setup.

  • richardhermanrichardherman not-so-junior member Posts: 286

    Does the setup page on the device actually work? can you navigate through the setup?

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Yes, it does still work I can navigate. I do have a default page set up in my program.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,605

    Again, what happens when you send a page show command to the panel? Does it work, does it exit setup?

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    What do you mean by "send a page show command" How do I do that?

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,605

    From your Netlinx program or from NetLinx Studio, tell the panel to show a named page.

  • richardhermanrichardherman not-so-junior member Posts: 286

    Not sure if it's even possible, but you aren't accidentally using TPDesign5, are you?

    For showing a page with NetLinx studio: menu 'diagnostics' > 'control a device'. In the 'device to control' section fill in the D:P:S of your panel, something like Device:10001, Port:1, System:1. In the 'message(s) to send' box, type the command as you would in code. something like: 'PAGE-pagename' (without the quotes) . set the message type to command and press 'send to device'

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Uhhhh... Yes, I am using TPDesign5....

  • richardhermanrichardherman not-so-junior member Posts: 286

    Oh, the MXT-1000 is a 4th generation panel (G4) and needs TPDesign4. TPDesign5 isn't just a newer version of TPDesign, it's exclusively for 5th generation panels (G5).
    I wouldn't have thought it would be possible to do that, to be honest. But there you go.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,605
    edited November 2020

    Richard's point being that a V5 project isn't valid if loaded into a V4 panel... there's no place to go so the setup dialog can't be dismissed. The panel is probably fine. Make a V4 project for it.

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Okay then, I will try in the morning to upload a G4 file.

  • SeoulhawkSeoulhawk Junior Member Posts: 9

    Bingo! That was it. I had sent a TPD5 file to it. Now it's time to start trying to learn again.

Sign In or Register to comment.