Home AMX User Forum AMX Technical Discussion
Options

Please help with NX controller

Hi guys!

I've bought an used NX-2200 controller and it suppose to works.

When I power up the controller, the status green led is on and anything esle is on or blinking.

I've tried to connect by TCP/IP and USB and it's impossible to connect. I've tried to press and hold ID button for 10 seconds to factory default.

Anything I try is not working...

Any suggestions?

Many thanks!

Comments

  • Options

    Put the controller in PRD mode (configuration dipswitch-1 on) and reboot.
    This prevents the execution of the present program.
    Another possibility is a faulty SDCard, for this you need another unit to temporarily exchange the SDCard.

  • Options

    I've tried PRD mode and nothing works.

    Where is SDCard ? Inside the controller ?

    Thanks!

  • Options

    I have heard reports from multiple eBay buyers who purchased NX series controllers that were removed from installations and "sanitized" by the seller. Their process included removing the SD card all together from the unit, and it will not boot without this.

  • Options

    Many thanks guys!

    Good news is :
    SDCard is inside (I cleaned connectors)

    Bad news are :
    Controller doesn't start (even in PRD mode)
    Ethernet connector LED's doesn't light when I plug network cable
    I've tried to read SDCard content with PC and it's impossible to read the content (maybe is't normal, I don't know)
    ID button change nothing (I've tried 10, 20, 30 and 60 seconds)

  • Options

    The ID button factory reset can be tricky. See ie. https://proforums.harman.com/amx/discussion/138460/password-reset#latest

    The card is formatted with ext3 or 4 I think (Linux file system). You can read it on a Linux machine, did that often enough.

  • Options

    Even with a defect SD card, you should get at least one "Knight Rider" when powering the NX, so all LEDs at front will turn on left to right, and off again. This is the init test for the main board.

    If this is not happening, remove power, and remove the SOM board (the small board with the SD card on it), and try again. If now the "Knight Rider" will come once (nothing more will happen without the SOM), by experience this means that the SOM board itself is defect, and needs to be replaced (recommending to also replace the SD card).

    As serial number and MAC addresses must be programmed onto the SOM board, this only could be done by Harman service. You may have to contact them directly to check options.

  • Options
    John NagyJohn Nagy Posts: 1,736

    Moral of the story: If buying used, test immediately to preserve refund rights.

  • Options
    Ad_My_XperienceAd_My_Xperience Posts: 73
    edited December 2023

    I just bought another used NX-2200

    This one is booting normally but with "Listen Mode" in NS4, I don't find any device. Same thing with USB.

    I've tried with and without PRD mode.

    There is no program port in this kind of controller like NI series, so I don't know how to find IP...

    I've tried "ID button" 5-6 times ti try to factory reset but nothing happen (doesn't reboot).

    I've isolated the controller and my computer onto their own temporary network to reduce the amount of network chatter going on. I start a wireshark capture with a display filter udp.port == 1319. In the resulting data, I see source and destination IP addresses. I've tried to connect NS4 with both and again, nothing happens

    Any idea?

  • Options

    Comparing the source and destination IP, they are not in the common 255.255.255.0 subnet range.

    When connecting the NX with your PC, it should come up as a USB Serial Device. I would give a try first with "Tera Term" console program, as it would list any USB COM ports. Connect to the NX with baudrate 115200, and you should get access to the console.

    The factory Reset by ID button is a bit tricky, as the LED pattern in the manual isn't fully matching to the controller's behavior. Holding the iD button too long may cause the NX to go back to factory firmware image, but is doing also the factory reset, then you can build up again the firmware.

  • Options
    HARMAN_ChrisHARMAN_Chris Posts: 598
    edited December 2023

    The easy answer is to plug into the ICSLan port. Your computer will receive an IP.
    1) Open command prompt:
    2) issue an ipconfig /all command to see the GATEWAY of the wired port
    3) Open a telnet window to that IP address.
    4) This should be the ICSLan IP of the controller (the item that issued your current wired DHCP address)
    5) issue a get ip command and it will reveal the LAN IP of the NX2200
    6) issue a set ip command and update it to what you want

  • Options

    Hello Chris,

    When I open a telnet session with gateway IP (198.18.0.1) I need a login and password.

    I've tried with : administrator (password), admin (password), netlinx (password).

    How can I reset login and password ?

    Thanks!

  • Options

    Factory Reset by the ID button...

  • Options
    Ad_My_XperienceAd_My_Xperience Posts: 73
    edited December 2023

    I've tried factory reset holding ID button 5, 10, 15, 20, 25, 30, 35, 40, 45, 50, 55 and 60 seconds

  • Options

    Switching to Static or Dynamic IP Addressing.
    To toggle between static or dynamic IP addressing, the controller cannot be currently booting or it must be in ID Mode. If these
    conditions are met, holding the ID pushbutton for 10 seconds changes the current IP addressing mode.
    Restoring the Controller Settings to the Factory Defaults
    To restore the controller settings to the factory defaults, the controller must be currently booting and you must press the ID
    pushbutton for 10 seconds. The controller is booting when the Status, Input, and Output LEDs turn on briefly then turn off. Shortly
    after, the Status and Input LEDs blink periodically. Resetting to factory defaults includes resetting the static IP address to its default
    and deleting the NetLinx program.
    CAUTION: Pressing the ID pushbutton for 20 seconds restores the factory firmware image on the controller. Do not press the
    pushbutton significantly longer than the necessary 10 seconds if you only want to restore the default settings on the controller.
    Restoring the Controller’s Factory Firmware Image
    To restore the controller’s factory firmware image, the controller must currently be booting and you must press the ID pushbutton
    for 20 seconds. This also deletes all code and IRL files.

    https://amx.com/en-US/site_elements/hardware-reference-manual-nx-series-netlinx-nx-integrated-controllers

  • Options

    I see in Chris's post, the controller is booting when the Status, Input and Output LEDs turn on briefly then turn off

    In any way, Status LED is never ON, it's always OFF (when I power ON the controller and when boot is complete).

    I think it's my problem....

Sign In or Register to comment.