Home Duet/Cafe Duet

Duet Error

RonenRonen Junior MemberPosts: 55
Hi all,
Got a question for you, I have downloaded the Russound SMS3 module that AMX has released lately, but, when I try to compile it, it gives me the error:
ERROR: (0): L20219: File not found: [devicesdkrt.jar] version [1.8.0]

The "devicesdkrt.jar" file does exist and i have a valid path for it in the Netlinx compiler options.
Tried to reinstall the latest Netlinx Studio software but to with no luck.

Got any ideas?

Thanks
Ronen

Comments

  • Marc ScheibeinMarc Scheibein Junior Member Posts: 669
    Ronen,

    this error indicates that you still don't have the Duet Runtime Environment to v1.8 installed. v1.8 was released a few weeks after Studio 2.5 was available, so it's still not part of the NSX installation.

    Updating the Duet Runtime Environment is done by WebUpdate.
    When Webupdate has beenn started,
    1) click OPTIONS, check the "Ignore existing installed applications..", so you get all tracked applications.
    2) click "Check for selected updates"
    3) now you should get several apps listed
    4) select "Duet Runtime Environment" only
    5) download and install it

    Hope this helps,
  • Stephen BoltonStephen Bolton Junior Member Posts: 345
    Ronan,

    This happened to me recently too (different module) - my Duet Runtime Environment was V1.7 and the module was V1.8.

    It turned out, in my case, that there was a second .jar file posted with the module which allowed 1.7 or 1.8 DRE to be used. At that time V1.8 DRE was beta and the module was posted with both flavours.

    You could see if both were posted.

    What I am not sure about is any issues regarding backward compatability of modules..will a V1.8 DRE compile a V1.7 DRE based module?

    Would think so, but haven't tried it.
  • RonenRonen Junior Member Posts: 55
    Hmmmm.....

    Marc,
    Thanks for the answer, i can't use the webupdate here in the office, i think it's because of some firewall rules...

    I'm gonna try this at home later on today, but it seems that you are right.

    i'll post for any changes

    Thanks,
    Ronen

    p.s. have any idea what ports should be open for webupdate?
  • Marc ScheibeinMarc Scheibein Junior Member Posts: 669
    Ronen wrote:
    Marc,
    ....
    p.s. have any idea what ports should be open for webupdate?

    Hm, only port 80 is required... But for me it's similar. In company, i can do webupdate without any problems, but at home I get curious error messages from webupdate although I use the same user and pass for login at AMX..... :(
  • RonenRonen Junior Member Posts: 55
    All Good

    Marc,
    finally I managed to download the duet runtime update... and yes it solved the problem.
    Thank you all again for the help!

    Ronen
    Btw I had to disable the windows firewall and my hardware firewall (Fortinet) for it to work...
Sign In or Register to comment.