TP4 Buglist - Add one for me

124»

Comments

  • jjamesjjames AMX Sustaining Engineer Posts: 2,898
    You can always email it in to the US team.


    Sent from my iPhone using Tapatalk
  • C.HouliarasC.Houliaras Junior Member Posts: 53
    I called it in today. They sounded surprised to hear about it, so hopefully they fix it soon. It's an incredibly annoying bug for me.


    Sent from my iPhone using Tapatalk
  • C.HouliarasC.Houliaras Junior Member Posts: 53
    Jorde_V wrote: »
    You know you love it ;)


    Unfortunately my point of contact is the NL/UK and they can't do anything with it except report it to the US (is what they say, but it takes them weeks to do so)


    Your point of contact is the US I reckon?
    Yes, I'm in the US.



    Sent from my iPhone using Tapatalk
  • Jorde_VJorde_V UX Scientist Posts: 393
    What is the email of the US team then? I'll drop them e-mails in the future then.
  • C.HouliarasC.Houliaras Junior Member Posts: 53
    Jorde_V wrote: »
    What is the email of the US team then? I'll drop them e-mails in the future then.

    [email protected]


    Sent from my iPhone using Tapatalk
  • Quick Input -> Text is not working properly for me. If I hold Ctrl + Enter, it's not moving to the next line anymore.

    v3.1.0 Build 643 - Worked in the previous version.

    This issue has been fixed in v.3.2 Build 661. In-place editing of State Text has been restored to it's previous implementation.

    Unfortunately, this means that in-place-editing using complex-script languages such as Arabic and Hebrew will not be supported in the in-place edit control. But I suspect most users will use the "Enter Text" dialog for that anyway.

    FYI, while I'm on the subject, the "Enter Text" dialog is now resizable. Not a feature you'd use often, I suspect, but it should help occasionally.
  • BigsquatchBigsquatch Junior Member Posts: 216
    Here's a bug that caused me some grief a few months back. I was working with the Deanna user interface from GUIFX (http://www.guifx.com/amx-ui-kits/deana-5). In that template there are two popups that you are intended to show pretty much all of time. The icons on the left side of the screen ("quick keys") and the bar along the bottom ("footer") are what I'm referring to.

    In the middle of the screen is a 3rd popup for activities. I had more activities than would fit on that popup so I had a second popup for them. After going back to the 1st popup the activities buttons would no longer work. I figured out that the "footer" and "quick keys" worked but not the activities popup. If I did all of the page flips through code I still had the same problem. If I ditched the "footer" and "quick keys" then the problem disappeared.

    It turns out that "quick keys" and "footer" were named "_UI - Quick Keys" and "_UI - Footer" in the TPD4 file. Once I got rid of the underscore characters at the beginning of the popup names the problem went away.

    Edit: Ooops! This could be a TPControl bug and not a TPD4 bug. I don't have a working touch panel to test on and find out.
  • feddxfeddx Junior Member Posts: 140
    Not really a bug...

    ...But a future feature I'd like to see,

    Scalable images on buttons. It would be good to have the ability to scale an image with the button. This way when you change the button size, the image changes too. AND allow the designer/programmer to enable/disable this feature.
  • JeffJeff Junior Member Posts: 374
    I'm having a weird issue that is hard to nail down, but i've seen it for quite a while now. I have a single layout I use for almost all of my projects, and very often I'll copy and paste buttons between panels/projects. This seems to happen the most when I'm doing that, although that may not be the issue.

    What happens is that sometimes buttons have their bitmaps and/or chameleon images randomly change. Buttons I wasn't working on. I might have copied or pasted the same bitmap that was on that button somewhere else in the file, but not necessarily. So you'll end up with a situation like this.

    1) Button 1 has the bitmap imbutton1.png
    2) Button 2 has the bitmap imbutton2.png

    I do some copying and pasting of random other things around the panel, then I come back to this page, and I notice the following

    1) Both buttons 1 and 2 visually on the panel show imbutton1.png
    2) If I look at button 2's bitmap properties, it still SAYS imbutton2.png
    3) If I close and reopen the file, now button 2 says imbutton1.png, and actually is imbutton1.png

    This happens with things like buttons with no bitmap that are just text labels all the time, randomly a text label will have the background image of a button.

    I wish I could give more specifics but it happens so intermittently that it's hard to nail down, but I do see it on a regular enough basis that I'm confident this isn't me accidentally selecting a button and pasting an image to it.
  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,509
    I saw exactly the behavior you are describing a number of times, but not for the last year or more.
    If I continued to futz with it once I saw that, it would soon crash, and sometimes saves were corrupted after seeing the symptom.

    It hasn't happened here in a long time. Don't know why.
    Save often in new files so you have a way back, make notes of the changes you make between saves, and be sure you have the latest TPDesign, that's really all I can suggest.
  • JeffJeff Junior Member Posts: 374
    I just double checked and I'm using TPDesign 3.3.674, which is the newest version, and it is showing up in files that were created 3 weeks ago based on the downloaded Modero X templates from the AMX website. So unless those templates were created so long ago that they have whatever corruption in them, it's probably not corrupted files.

    Of course, it's always possible those files have been kicking around and were made in old version of TP4, or are otherwise corrupted, but I'm in the oddly unique situation of only working on very new stuff at the moment, which is pretty rare.
Sign In or Register to comment.