Home NetLinx Modules & Duet Modules

AMX Jandy Module..

cmacma Junior MemberPosts: 94
I usually write my own code but due to being in a pinch I used the Jandy Pool control module that AMX has written. Over the last month or so the Jandy Aqualink RS has been replaced once and the new one still ocasionally locks up. AMX will still be sending the polling commands every 3 seconds but the Aqualink does not respond until power is removed and put back. Tech support at Jandy thinks the unit could possibly have a loose power connector causing intermittent power outages and by reseting the power to the unit it is coming back online. Anyway, I am trying to determine whether there is a programming issue or an installation issue and of coarse I am programming this remotely and cannot go onsite to verify what the tech is telling me. Anyone out there using the same module and having problems?

Comments

  • DHawthorneDHawthorne Junior Member Posts: 4,584
    cma wrote:
    I usually write my own code but due to being in a pinch I used the Jandy Pool control module that AMX has written. Over the last month or so the Jandy Aqualink RS has been replaced once and the new one still ocasionally locks up. AMX will still be sending the polling commands every 3 seconds but the Aqualink does not respond until power is removed and put back. Tech support at Jandy thinks the unit could possibly have a loose power connector causing intermittent power outages and by reseting the power to the unit it is coming back online. Anyway, I am trying to determine whether there is a programming issue or an installation issue and of coarse I am programming this remotely and cannot go onsite to verify what the tech is telling me. Anyone out there using the same module and having problems?

    I have a home-grown module that does the same. I cry "bull" on the Jandy people - it's a flaw in the product. My module has a timeline that fires a relay, resetting the Jandy interface if it doesn't hear from it in the span of a minute. Someone at tech support there told me I could also reset it by asserting one of the comm lines (DTR, maybe?), but I never got around to it, the relays worked.
  • Spire_JeffSpire_Jeff Formerly Caffeinated Programmer Posts: 1,917
    I am using the AMX comm module on a couple of projects. On both projects, I had to deal with defective RS boxes. The unit on the first project failed after about 2 weeks (nothing including power cycling would bring it back) and on the second project, the original unit was DOA. After I got things working, I did have the second project experience a failure after about 3 months, but I think that was due to the unit being placed near the pool equipment. On both projects, I wound up moving the Aqualink RS box right next to the processor and getting it out of the pool control room (even tho the pool guys didn't like this idea). Since then, I have not had any problems. These projects have been running for 3 years and 2 years solid now (until I posted this I'm sure ;) ).

    Jeff
  • cmacma Junior Member Posts: 94
    This box is sitting on top of the NI-4100 so it is definately not in the pool EQ room. I did a search on the Yahoo C forum and found similar issues there. Seems like alot of people have problems. I am going to try controlling the RTS setting, changing it to low and back to high for the reset. Thanks, I have programmed many projects remotely with no issues but this one is killing me, we also have thermostats that are turning themselves off in the middle of the night so I created an array to record all of the transmissions being sent out from AMX and labeling them as to whether they came from a scheduling command or a TP press, and I am also recording all of the commands coming back from the TStats. Once again on Sunday night at 12:30am 2 of the TStats replied that they had turned to the off mode while there were no commands sent from AMX..
  • PyroGuyPyroGuy Junior Member Posts: 111
    dying RS

    I also had a jandy RS module go MIA. It ran for a while and then died. It was replaced and everything was fine - for a while.

    It died again and Jandy replaced it again. Then it died after several months.

    The pool people were going to bring a replacement but it never happened.

    Feedback from Jandy was they seemed to have identified a power issue on board for the pool control system and it was, in effect, killing the RS unit.

    Our client basically gave up and turns the jacuzzi on with the pool controller - not the AMX TP. Unfortunately, the pool controller was a nice source of temperature data for the TP home page.
Sign In or Register to comment.