Home AMX User Forum AMXForums Archive Threads AMX Applications and Solutions VisualArchitect

Still getting no 232 response

kmenshousekmenshouse Junior MemberPosts: 32
I'm just beginning to use VA and just updated to 1.3. Everything is going smoothly except I'm getting no response from any 232/422 devices at all. I have checked and double checked the pinouts. I'm trying to control a Precis LT video switcher, a Matrix MI8 audio switcher, a Viewstat and a Yamaha RXV2700 receiver. All of those have Duet Modules and are selectable under devices. I'm must be missing something IF this is supposed to be a reliable programming option.

Any thoughts would be greatly appreciated.

Keith

Comments

  • CT-DallasCT-Dallas Junior Member Posts: 157
    Are you at least getting one-way communication-meaning, are the devices responding to the commands but not reporting back?

    Have you opened the code in netlinx studio and turned on device notifications to see if the strings are being sent and if anything is being returned?

    heads-up on the precis module - there is no volume control as of yet if you need it... The commands are there, but there is no VA use for them. You will need to write those blocks of code in the custom.axi. Additionally, the precis LT has audio switching, but not digital volume control. Your matrix piece is probably handling that, but the lack of DVC on the precis was a huge kick in the gut on a recent project.
  • kmenshousekmenshouse Junior Member Posts: 32
    Thanks Chris for the suggestions. I did monitor it in Netlinx Studio. The strings can be seen going to the device from the panel but not strings coming back. The device responds for a while and then locks up the whole system. So far I've only worked on the Yamaha receiver, so I'll try some other devices this afternoon. So far I'm not very impressed with the millions that supposedly has been spend on VA.
  • CT-DallasCT-Dallas Junior Member Posts: 157
    I would agree that it is "not there yet" - but the potential for the product is emense. If you think about what the software has to do, I find it quite remarkable. Breakthroughs like one port controlling multiple zones (i.e. lighting) will take the product a long way. This will allow for substantial improvement in the autopatch line - more specifically with zone volume control. Again - it does not do it all at this time, but with custom code, you can get a great start with VA and then take it the next step of the way with the custom code.

    I think that in two years, this will be rock solid and something that will significantly simplify my project programming for average size projects.

    With a good deal of work, VA can currently run a whole house, but AMX is quick to point out that at this state, it is intended for a single room. It sounds like your scenario is a single room, so I think you have the right tool.

    have you gone through the VA tutorials online? I learned a good deal about what the product can do by going through those.

    If you get stuck, call tech support. There are several guys who are very experienced with VA and may be able to spare you some frustration. With a product like VA that is really in a perpetual state of development, I think they would rather you call within the first 5 minutes of the problem than to get frustrated for an hour and then call or hit the forums with a rant. Not that your post was a rant, but you know what I mean. I have upchanneled several bugs and/or feature requests and the VA team has been VERY responsive. Ultimatly, they really want this to be a time saver for dealers - not a source of frustration. They want us to use it, and would like to know why dealers have had bad experiences so they can fix the problems.

    If you have not already called about it, I would - they want to help.

    Chris
Sign In or Register to comment.