Home AMXForums Archive Threads AMX Applications and Solutions VisualArchitect

Error Message after Installation of VA 1.4.1.232

DaeniDaeni Junior MemberPosts: 1
Hi everybody,
I'm new to all this and will attend Programmer 1 here in Switzerland next week.

I received a Disc to pre-Install the VisualArchitect on my Laptop prior to the course.
When I try to start the software I get the following Error-Message:
=====================================================
Invalid Version
The Device Databasehas not been properly installed; Version 1.3.50 is required.
Please install and then re-launch VisualArchitect.
=====================================================

I run Windows Vista Home Premium 32bit Service Pack 1 on the Laptop. Manually searching for that file in the AMX TechCenter or trying to get the WebUpdate to find it did not help so far.

Does anybody have an Idea or the possibility to get me the needed Version 1.3.50

Many thanks in advance.

Comments

  • Marc ScheibeinMarc Scheibein Junior Member Posts: 669
    Please give it a try:
    ---
    Device Database 1.3.50 is required
    This error occurs when attempting to run VisualArchitect 1.4 on Windows Vista. Even though the user running the application may have administrator rights, this error occurs. The solution is to prior to launching VisualArchitect, is to select the desktop icon for VA and open up the properties dialog. After the property dialog is open, select the Compatibility tab and then select the check box for Run this program as an administrator.
    ---
  • mhtoomesmhtoomes Junior Member Posts: 1
    I am getting the same error message and I'm running Windows XP. I went into properties of VA, but the same options are not available in XP. Any ideas?
  • The Device Database has not been properly installed; Version 1.3.50 is required

    We have received a few complaints on this message and have found an effective method to restore the application databse.
    Try this:
    Uninstall VA, uninstall Microsoft SQL Server (select the AMX instance AND the client support piece), manually delete C:\Program Files\Common Files\AMXShare\VASupportFiles\ and C:\Documents and Settings\All Users\Application Data\AMX\VisualArchitect\, then re-install VA (which will, in-turn, re-install MSSQL).
  • d-alonsod-alonso Junior Member Posts: 5
    I had a similar problem with the same message and I did all the removals with no sucessfull results. I finally solved the problem because I noticed there was a SP3 For MSXML6 that failed to install in the windows update and in the VA in would fail also. So I removed VA and then used REGCURE program It still failed so I then used the Windows Installer Cleanup Utility (Download from Microsoft) and Killed the MSXML6 Install and only the I was able to install the VA Program. Then i did the windows update to get the MSXML6 Service Pack and it is working Fine....In it does not work for you check that you can get the MSSQL to install correctly before trying it again..

    Hope you get yours working

    David

    PS I have XP Pro SP3
  • sijonessijones Junior Member Posts: 16
    I get the same problem with Windows 7. Does anyone know if there is a version of the VA installer that is packaged with the SP3 version of SQL Server 2005? I believe that this will fix the issue as the installation of SQL Server 2005 fails as part of the VA install.

    Kind regards,

    Steve
  • mrhoadarmrhoadar Junior Member Posts: 14
    Just finished dealing with the same problem. Here are two good Microsoft sites that describe the problem and the fix.
    http://support.microsoft.com/kb/968749
    http://support.microsoft.com/kb/290301

    Michael
Sign In or Register to comment.