Home AMX User Forum AMX Design Tools

Anyone Know How to Stop TPD4 from Crashing?

TurnipTruckTurnipTruck Junior MemberPosts: 1,485
Running Windows XP SP3 with the latest version of TPD4. It crashes almost every time I try to connect to the master to upload panel files.

TS had me remove the program and its registry entries then reinstall. Worked better for a short time then same thing.

I habitually disconnect after a transfer as that seemed to have helped in the past.

Thanks for any suggestions.

Comments

  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    I had a terrible time with TPD crashing. Since I've moved to Windows 7, it's gotten a little better. But, if you make the mistake of not disconnecting the master and rebooting/uploading your are always clicks away from a hard crash. I usually just restarted the program right after making the mistake knowing it was my only chance to keep it from hard crashing my computer.
  • TurnipTruckTurnipTruck Junior Member Posts: 1,485
    In my case it's just the TPD4 program that crashes, not the whole PC. The program can be retarted, but usually crashes again at the next master connection.

    This has been an issue for so long that I'm beginning to think that it only happens in PCs not residing in Texas.
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    In my case it's just the TPD4 program that crashes, not the whole PC. The program can be retarted, but usually crashes again at the next master connection.

    This has been an issue for so long that I'm beginning to think that it only happens in PCs not residing in Texas.

    Well, not that this suggestion is a 'little thing.' But, I have found that my AMX software seems to run a little better under Win7. Perhaps it's time to look at moving to last year's OS.
  • truetrue Junior Member Posts: 307
    I've had this issue, often when transferring R4s.

    Open TPD4, create a new panel file, close it. Don't worry about saving it. Open your original panel file and try transferring - it'll probably not crash this time.
  • jjamesjjames Just another dude Posts: 2,906
    I'd have to agree with Eric, Win7 (64-bit for me) seems to make things a bit more pleasant. I'm always floored when people say NS3 and TPD4 crash constantly, they crash on me maybe once every 2-3 weeks if that.

    I do seem to remember TPD4 crashing more under XP for some reason.
  • viningvining X Member Posts: 4,368
    For me it usually happens when I have TPD4 connected to the master and I then do a NS3 file xfer which forces the master offline which in turns drops the TPD4 connection. TPD4 is usually not happy after this and will often crash. I often try to close the TPD4 connection before sending a NS3 but usually forget.
  • jjamesjjames Just another dude Posts: 2,906
    Hmmm - that's strange. I almost always forget I'm connected via TPD4 when I'm transferring code; I rarely -- if ever -- disconnect from the master in TPD4, I just wait for it to happen. I can't recall it happening under these circumstances in Win7, but I seem to remember this was the cause in XP.
  • viningvining X Member Posts: 4,368
    Yeah, I'm still running XP on my MAC pro and OP (TT) is on XP too. I would love to switch to 7 but it's way to much work to convert my MACs. Maybe in a coulpe more years.
  • TurnipTruckTurnipTruck Junior Member Posts: 1,485
    Nice to hear that it works better under Windows 7. However, XP seems to be the most stable Windows I've ever used. To go to a new OS across several machines just to accomodate the AMX software seems a bit overkill. Someone, somewhere MUST know why it is crashing and how to fix it. Trick is to get that person to talk!
  • viningvining X Member Posts: 4,368
    Nice to hear that it works better under Windows 7. However, XP seems to be the most stable Windows I've ever used. To go to a new OS across several machines just to accomodate the AMX software seems a bit overkill. Someone, somewhere MUST know why it is crashing and how to fix it. Trick is to get that person to talk!
    Well that person hasn't come forward in the last 2+ years that this problem has been prevalent. It would be a crule joke for them to come out now that most folks have migrated to 7.

    I'm sort of numb to it now and it doesn't bother me as much as NS3 crashing which happens more frequently than TPD4. I think that's mostly due to having 2 instances of NS3 open at the same time with both running diagnostics & debug viewing somewhat large structures while having numerous files open.
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    I had a lot of crash issues in the beginning, but they mysteriously have gone away. Once in a blue moon I get one, and I can't begin to tell you what has changed ... not my habits, that's for sure. Well, except for one thing: I save a lot more frequently now.
  • jjamesjjames Just another dude Posts: 2,906
    I have my auto-save set to every 2 minutes. I forget what version it was that I learned that quickly - maybe 2.7?

    If anyone doesn't know where Auto-save is, it's under Preferences -> Workspace.
Sign In or Register to comment.