Home AMX User Forum AMXForums Archive Threads AMX Hardware
Options

R4 has Insomnia

I have a brand new R4 in my office that won’t stay asleep. Every 30 seconds to 3 minutes it wakes up all on its own. It doesn’t matter if the R4 is in the cradle or laying flat on a desk and it doesn’t matter if the gateway is powered on or not or if any NI masters are powered on or not. The darn thing just keeps waking up. Anyone else experience this? Maybe the tilt switch is flaky?


The continual flash from the screen and high pitched squeal from the backlight is getting on my nerves so my only option right now is to let the battery die.
«1

Comments

  • Options
    viningvining Posts: 4,368
    I have a new one sitting on my desk too that constantly wakes up. Sleep apnea?
  • Options
    a_riot42a_riot42 Posts: 1,624
    vining wrote: »
    I have a new one sitting on my desk too that constantly wakes up. Sleep apnea?

    I haven't seen this but have had customers complain about it, waking them up in the middle of the night. Try keeping in your hand while it boots, and then putting it in the cradle once it has booted. I believe the touch sensor calibrates to your hand after a reboot, and so if it boots while in the cradle, then the touch sensor is too sensitive and can wake up randomly.
    Paul
  • Options
    viningvining Posts: 4,368
    a_riot42 wrote: »
    I haven't seen this but have had customers complain about it, waking them up in the middle of the night. Try keeping in your hand while it boots, and then putting it in the cradle once it has booted. I believe the touch sensor calibrates to your hand after a reboot, and so if it boots while in the cradle, then the touch sensor is too sensitive and can wake up randomly.
    Paul
    I just tried this so we'll see if that does the trick but this means we'd have to do this procedure after every file transfer since that requires it being in the dock and then it reboots itself after the xfer thus ressetting to a more senstive setting. This also means that it is likely more wide spread but since we're not on a job long enough or specifically paying attention to them while we are it goes unnoticed and the ones on our desks are litterally in our face all the time so they get noticed.
  • Options
    a_riot42a_riot42 Posts: 1,624
    vining wrote: »
    I just tried this so we'll see if that does the trick but this means we'd have to do this procedure after every file transfer since that requires it being in the dock and then it reboots itself after the xfer thus ressetting to a more senstive setting. This also means that it is likely more wide spread but since we're not on a job long enough or specifically paying attention to them while we are it goes unnoticed and the ones on our desks are litterally in our face all the time so they get noticed.

    For some reason only some of the R4s I have used have this issue, and I don't know why. Perhaps it only needs to be done after a firmware upgrade or some other variable. Perhaps there was a hardware version that had this problem and it was fixed. I have mentioned it to clients and they seem to be able to do this easy workaround if the remote exhibits this issue without too many complaints. It would be nice if AMX could figure it out and provide a solution though.
    Paul
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    a_riot42 wrote: »
    I haven't seen this but have had customers complain about it, waking them up in the middle of the night. Try keeping in your hand while it boots, and then putting it in the cradle once it has booted. I believe the touch sensor calibrates to your hand after a reboot, and so if it boots while in the cradle, then the touch sensor is too sensitive and can wake up randomly.
    Paul

    Thanks for the suggestion Paul. Rebooting it my hand might have slowed down the frequency of wakeups somewhat but it’s still exhibiting the same issue. I put a stopwatch to it before and the longest it slept for was about 3 minutes but most of the time it woke up in less than 1 minute, sometimes less than 30 seconds.

    Here are the sleep times after rebooting in my hand:

    05:54
    01:53
    00:34
    03:10
    00:53
    01:14
    02:58
    00:26
    00:37
    03:37
    04:24
    00:32
    01:21
    02:20

    I don’t see any pattern to these continual wakeups but it’s definitely still having issues staying asleep.
  • Options
    a_riot42a_riot42 Posts: 1,624
    Joe Hebert wrote: »
    Thanks for the suggestion Paul. Rebooting it my hand might have slowed down the frequency of wakeups somewhat but it’s still exhibiting the same issue. I put a stopwatch to it before and the longest it slept for was about 3 minutes but most of the time it woke up in less than 1 minute, sometimes less than 30 seconds.

    Here are the sleep times after rebooting in my hand:

    05:54
    01:53
    00:34
    03:10
    00:53
    01:14
    02:58
    00:26
    00:37
    03:37
    04:24
    00:32
    01:21
    02:20

    I don’t see any pattern to these continual wakeups but it’s definitely still having issues staying asleep.

    What are the sleep settings you are using? Is the sleep on display timeout used?
    Paul
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    a_riot42 wrote: »
    What are the sleep settings you are using? Is the sleep on display timeout used?
    Paul

    Display timeout has always been 10 seconds.

    The sleep settings for the test I posted was 5 minutes and Sleep on Display Timeout was disabled.

    I’ve tried different sleep settings before - 0, 3 minutes, 5 minutes. If I use Sleep on Display Timeout the wakeups seem to occur more regularly either every 90 seconds or so or 3 minutes. Hard to tell though and I’m getting bored sitting here with a stopwatch timing it.
  • Options
    a_riot42a_riot42 Posts: 1,624
    Joe Hebert wrote: »
    Display timeout has always been 10 seconds.

    The sleep settings for the test I posted was 5 minutes and Sleep on Display Timeout was disabled.

    I’ve tried different sleep settings before - 0, 3 minutes, 5 minutes. If I use Sleep on Display Timeout the wakeups seem to occur more regularly either every 90 seconds or so or 3 minutes. Hard to tell though and I’m getting bored sitting here with a stopwatch timing it.

    Try 20 seconds and sleep on display timeout set to on. This is what I had set when mine were doing the same thing. It might not make any difference but its obviously a hardware/firmware bug, since this can happen even without being connected to a system.
    Paul
  • Options
    viningvining Posts: 4,368
    Since rebooting in hand (two hands and fidgeting slightly) I haven't notice it wake up on its own since but I am preoccupied with other things so it may have and I just didn't notice.

    My R4 is set to timeout at 30s and sleep at 3m.
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    a_riot42 wrote: »
    Try 20 seconds and sleep on display timeout set to on. This is what I had set when mine were doing the same thing. It might not make any difference but its obviously a hardware/firmware bug, since this can happen even without being connected to a system.
    Paul

    Nope,still doing it. The first wakeup happened only 13 seconds after the 20 second timeout with the sleep on display set to on. Now it’s waking up with under a minute of sleep. It’s seems so sporadic. I'll try rebooting again in my hand with these settings.

    I had a different R4 here in the office early this year and I don’t remember seeing the problem with that one.
  • Options
    a_riot42a_riot42 Posts: 1,624
    Joe Hebert wrote: »
    Nope,still doing it. The first wakeup happened only 13 seconds after the 20 second timeout with the sleep on display set to on. Now it’s waking up with under a minute of sleep. It’s seems so sporadic. I'll try rebooting again in my hand with these settings.

    I had a different R4 here in the office early this year and I don’t remember seeing the problem with that one.

    Yeah, it may have to go back from whence it came.
    Paul
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    vining wrote: »
    Since rebooting in hand (two hands and fidgeting slightly) I haven't notice it wake up on its own since but I am preoccupied with other things so it may have and I just didn't notice.

    I tried the 2 handed fidgety reboot with the settings that Paul gave me and it woke up 20 seconds after the timeout. Then it went to sleep for 4 minutes and I thought maybe it was fixed. But then after the 4 minute sleep it woke up and stayed awake for a full minute even though it has a 20 second timeout so I think it woke up while it was awake and delayed the sleep. Argh...

    Thanks for your input guys. I'm done messing with it.
  • Options
    John NagyJohn Nagy Posts: 1,735
    Note that any change in connection status can wake it up too. So if the gateway decided it needed a fresh grip on things, the panel lights. This can happen at any time in normal operation. So those, added to vibration and programmatic page sends can make the lighting occur more often and seem even more arbitrary.
  • Options
    viningvining Posts: 4,368
    John Nagy wrote: »
    Note that any change in connection status can wake it up too. So if the gateway decided it needed a fresh grip on things, the panel lights. This can happen at any time in normal operation. So those, added to vibration and programmatic page sends can make the lighting occur more often and seem even more arbitrary.

    Yeah but Joe's OP said he tried w/o gateway and w/o master, the R4 all on it's own which excludes all those possibilities but vibration.
  • Options
    a_riot42a_riot42 Posts: 1,624
    John Nagy wrote: »
    Note that any change in connection status can wake it up too. So if the gateway decided it needed a fresh grip on things, the panel lights. This can happen at any time in normal operation. So those, added to vibration and programmatic page sends can make the lighting occur more often and seem even more arbitrary.

    I don't think that is true, but if it is, that's poor design. Having an R4 light up in the middle of the night in a bedroom is just stupid, annoying and unnecessary.
    Paul
  • Options
    DHawthorneDHawthorne Posts: 4,584
    I've sen one go a step farther ... not only did it wake randomly (and constantly), but it pressed a button when it did so. The TV in the room kept coming on, and my customer was going nuts, and had to unplug his bedroom TV just to sleep. Baffled, I had it sitting on a counter while I scratched my head, when I noticed it waking up by itself, and beeping at the same time. I swapped it out with antoher R4, and the problem went away. When I sent it back to AMX, they "repaired" it witha recalibration ... I can only assume of the topuch panel sensitivity.
  • Options
    viningvining Posts: 4,368
    I caught mine with its eyes opened twice so far today so I suspect it's happening alot more. I unplugged the gateway to ensure it's not a programmed response although I'm pretty sure I have nothing in the program other than online event to run a custom event which doesn't work anyway. It's completely new this system and the only office R4 so I never programmed anything else. Basically it's just a paper weight at this point.
  • Options
    I think the touch sensors only calibrate themselves after power has been pulled for a small time period, but not from a soft reboot.

    Try pulling the battery out for 5 minutes and then hold the remote touching both side metal strips until it is completely finished booting up and let us know.

    That is the solution that I have used when I had a few customers complain about their R4s turning on by themselves and I have not heard the customer complain about the issue since.

    edit: For what it's worth... The next 4 big jobs will be using either URC or RTI remotes talking to their respective processors and RF antenna networks and shooting 232 or IP commands to AMX, so take that for what you will (this decision was not based on the cost of the remotes at all)....
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    the8thst wrote: »
    I think the touch sensors only calibrate themselves after power has been pulled for a small time period, but not from a soft reboot.

    Try pulling the battery out for 5 minutes and then hold the remote touching both side metal strips until it is completely finished booting up and let us know.
    I took mine out of the cradle and let it die a slow painful death this weekend. I put the dead R4 back in the cradle and held the sides with both hands while it rebooted and that looks like it did the trick. Thanks for the tip.

    Hopefully this issue gets resolved in a future firmware release.
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    After further review...

    After further review the call on the field has been reversed.

    It was okay for a few hours but now the R4 is back to its old tricks and it won’t stay asleep.
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    Just as a follow up the R4 needed to be sent back and the replacement works fine.
  • Options
    viningvining Posts: 4,368
    Joe Hebert wrote: »
    Just as a follow up the R4 needed to be sent back and the replacement works fine.
    So it's a hardware issue?
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    vining wrote: »
    So it's a hardware issue?
    In this case it was, yes.
  • Options
    viningvining Posts: 4,368
    When did your purchase your remote with sleep apnea? I presently have one on my desk which is one of five I purchased early to mid summer that exhibits the same type of behavior. Maybe there was a bad batch of R4s but the clients who got the other four aren't around enough to notice, plus I think they were added to the guest rooms anyway.

    I was hoping for a firmware fix but it looks like it's going to be an RMA.
  • Options
    Joe HebertJoe Hebert Posts: 2,159
    vining wrote: »
    When did your purchase your remote with sleep apnea?
    I ordered mine this year in the beginning of July.
    I didn't get around to opening the box until several weeks after I received it.
  • Options
    ColzieColzie Posts: 470
    Any movement on this? I get reports here and there of this happening but don't have any definitive solutions to offer.
  • Options
    jjamesjjames Posts: 2,908
    Try updating to the latest firmware on the R4 to 3.01.20. On the notes page, it only describes four fixes, but trust me, there's more in there. We've had very good luck so far with it. Had a client complaining the their R4 would not go to sleep, and after we updated to the latest revision - it's since been fixed.

    I think there's a hotfix available for the gateway as well - might want to call into tech support, explain your problems and ask them if the hotfix would correct the issues.
  • Options
    DHawthorneDHawthorne Posts: 4,584
    One of the advertised fixes in 3.01.20 is "Eliminates random touches." Seems to me that addresses it ... certainly random touches would provoke random wakeups.
  • Options
    jjamesjjames Posts: 2,908
    Still having clients complain about this, even though I thought it was fixed. Is anyone / everyone still having issues?
  • Options
    viningvining Posts: 4,368
    If you go back to Joe's post he had to send his in for repair to fix this issue. The firmware upgrades might just mask or minimize the issue if it actually did anything at all to address this problem.

    I'll plug my desktop R4 back in, upgrade if necessary and watch it to see if it is still acting up.
Sign In or Register to comment.