Home AMX User Forum AMX Design Tools

VPT Timeout During Upload

I have a VPT-CP (5964 series) Panel with 5.10a firmware. I am using TPD3 v3.16 Build 200 to attempt to upload the project from the panel. I have tried all baud rates...

In every case the upload begins as it should. The panel changes to the dark background and begins to display status messages:

Sending File

It hangs at this same place everytime. After about 10 seconds the Panel Beeps and the screen reverts back to the Main Panel it was on prior to the upload. After another few minutes the TPD3 Serializer Timeout Dialogue Pops Up indicating this could be caused by an invalid version of the panel firmware.

I tried TPDesign2 as well but, with this seeming to be a G3 panel I could not get anywhere with the transfer process there.

Can anyone HELP me? Any ideas why I am having this happen?
If it is related to firmware isn't 5.10a okay for a VPT-CP and TPDesign3..16b200 ?

I can't get the original project out of the panel for a backup before attempting to change anything!


  • Just some general thoughts...
    try with the panel on a power supply. Maybe it's on low batteries and cancels the upload. Any other software running on your PC which may use the serial port?
    If you work with a laptop, try with a power supply, too.

    Maybe a button on the popup or the HELP_POPUP itself is damaged. Maybe it must be deleted by the onboard editor.
  • ColinColin Posts: 51
    VPT-CP Timeout

    Yeah I had an issue, finally narrowed it down to Nokia software running on my pc which communicated with Com 1 - removing the software fixed the issue as the AMX software took precedence over my desire to "talk" to my phone.
  • glr-ftiglr-fti Posts: 286
    Have you noticed a message before it hangs that you are out of memory? If so set it back to factory default and then try the download again.
  • glr-ftiglr-fti Posts: 286
    Never mind. I just noticed that you are trying to do an upload not a download.
  • DHawthorneDHawthorne Posts: 4,584
    Actually, upload generally means you are sending files to the panel (some people use it oppositely, but most use the PC as point of reference), so it still may be memory.

    The latest version of TPD3 does not calculate memory use properly. You cannot go by that at all. If you run out of memory, there is a very brief message to that effect, then the panel resets; it's easy to miss. How many buttons are on your HELP_POPUP page? The "BB" on the loading screen tells you it is loading two buttons. If there are more, it is running out of memory and failing. If you have a memory problem, go through all your resources and delete any unused fonts, icons, and bitmap first, then trim out any pages that you might not be using and just left in in case you wanted to revert (heh, or am I the only one who does that?).

    If it's not a memory problem, I'd say there is an issue with that HELP_POPUP page, since it is the last to load. Temporarily delete it and see how the rest of it goes. Perhaps just re-creating it from scratch will fix it. If, however, you are using a large bitmap for your help screen, that may be the problem right there. G3 panels render those very slowly in any case, you may want to do it an different way.
  • alexanboalexanbo Posts: 282
    If you do too many read/writes to a viewpoint sometimes the memory gets a bit "corrupted" and it will act as if the memory is full even though it's not. To get around that I've had to reset it so that it clears everything in memory and loading from scratch. The button to reset is I believe on the screen that shows how many resources you're using.
Sign In or Register to comment.