Home AMX General Discussion

Compiler/Vista

JeffJeff Junior MemberPosts: 374
I'm running NS2 on my desktop (Vista) and my laptop (XP). When I compile on XP, it happens almost instantaneously. When I compile on vista, it hangs for a good 10 seconds before the compile actually happens, and the compiler is still technically "running" for 15 - 20 seconds after that. This means that if I fix a small error (missing bracket or something), and hit Compile again within that time limit, I get an alert that the Netlinx compiler is already running.

This is the only problem I have with NS2 on vista. Has anyone else run into this, and is there a known fix?

J

Comments

  • ColzieColzie Senior Member Posts: 470
    I have this same issue (Vista). It is most evident when I compile a module, then need to immediately compile the master file so I can send the code to the master. I don't know how many times I've hit F7 only to get the "I'm busy!" error. For me it is only 5-10 seconds. I've started to train myself to watch the mouse cursor and wait until the busy icon goes away before compiling again.
  • jason_the_adamsjason_the_adams Junior Member Posts: 108
    Hmm.

    I'm also running Vista on a laptop, running Netlinx 2.8b, but I don't get any sort of delay. One possibility, however, is that it's being caused one of the many Vista "features" that I've carefully stalked and destroyed. In any case, I suppose that means that the issue isn't permanent.
  • DHawthorneDHawthorne Junior Member Posts: 4,584
    My money is on the file indexing "feature." It may kicks in while you are editing, which is relatively low activity, then has to flush the cache and release resources before it switches over to your compiler. The post-compiler delay is probably just the write cache.
Sign In or Register to comment.