Home Crown Amplifiers

Why little sparking sound comming from my xls2002 and 2502 between some time intervals?

Hello. I newly purchased xls2502 and xls2002 amps. But with stabilizer or without stabilizer a sparking type sound comming from the amp between some time intervals.. But no issue in output sound quality. Stabilizer also creating sound a lot. The problem in amps remains same with or without stabilizer. Is that sound normal? Or any technical problem is there? Please help me..

Best Answer

Answers

  • SumitSumit Posts: 2
    edited November 2018
    I am using xls2002 for pair jbl jrx 218 subwoofer and xls2502 for pair of tops JBL jrx 225. With soundcraft signature 16 mixer. And my stabilizer is studiomaster svc-s5000va, 5kva
  • Maybe bad solder join, take care around the PSU transistor or the output stage. Check also any solder around cable connection. Maybe you can identify the problem when tapping with a isolated screwdriver on the PCB while running. If it make sparking when you touch somewhere, take a look closer about solder in this corner.

  • Hi DMX...
    Good call; I concur with your assessment, and it works even better in dimmed lighting so long as one keeps safety in mind.
    Do you know if this forum moderated at all? I've seen nothing indicating such. I replied to a topic started by another new forum member but they have not responded. 'Could be any number of reasons. I wanted a moderator to contact the forum member at their registered email address to let them know that people have responded to their post.

  • JensenJensen Posts: 9

    If the forum is moderated, its done quite poorly

Sign In or Register to comment.