Home dbx User Forum dbx General Discussion

hello i need the update that supports the new QSC K12.2 and EV Evolve 50

hello i need the update that supports the new QSC K12.2 and EV Evolve 50
its someone help me please !!!

Comments

  • HARMAN_EEldeHARMAN_EElde Posts: 1,214

    @morin67 said:
    hello i need the update that supports the new QSC K12.2 and EV Evolve 50
    its someone help me please !!!

    I'm not sure what update you are referring to but if it's the DriveRack PA2 you do not need specific speaker tunings for your equipment. Speaker tunings are not needed at all to run the DriveRack products, you can just select Not Listed in the Wizard setup and this will give you a default crossover curve.

  • morin67morin67 Posts: 2

    ok yes i have the driverack pa2 thanks for your help..... HARMAN_EELde

Sign In or Register to comment.