Home Lexicon Software

io 22 driver does not work on Mac OS Catalina !!!

io 22 driver does not work on Mac OS Catalina !!! it's a big problem! What can I do?) Help smb, pls!

Comments

  • I have the same problem. There's nothing you can do about it except downgrade. Lexicon must fix this with a new driver or we are all going to have to throw our soundcard to the garbage!
    Everybody with the same problem should complain...

  • HARMAN_EEldeHARMAN_EElde Posts: 1,076

    Hi guys. Unfortunately the IO Series have been discontinued for sometime (about 3 years) so the development life cycle has also ceased so a new driver will not be forthcoming. However, we have verified the driver works through 10.14 Mojave but no official testing/compatibility with 10.15 has been done.

    This has been helpful with getting our interfaces to be used in the past, follow this guide, even though it is a product for a different company and High Sierra, the menu options should be the same to follow.

    https://www.zoom-na.com/news/troubleshooting-product-not-recognized-mac-os-high-sierra-1013

  • Hello, guys! I've got the similar problem on mac with io-42. Driver was installed but Catalina doesn't seen the device. Ok, I have downgraded to Mojave, so no changes anyway.

    https://www.zoom-na.com/news/troubleshooting-product-not-recognized-mac-os-high-sierra-1013 - doesn't help unfortunately..

  • HARMAN_EEldeHARMAN_EElde Posts: 1,076

    @Vic_again said:
    Hello, guys! I've got the similar problem on mac with io-42. Driver was installed but Catalina doesn't seen the device. Ok, I have downgraded to Mojave, so no changes anyway.

    https://www.zoom-na.com/news/troubleshooting-product-not-recognized-mac-os-high-sierra-1013 - doesn't help unfortunately..

    We did test it as working with Mac 10.14 Mojave, so not sure, check the Audio/Midi Setup Application and try a different Frequency and Bitrate. Also if this is with Garageband as the DAW, you may want to try full uninstall and reinstall.

  • Hello, I have the same problem as you guys. Has somebody tried to contact the company for an updated driver? If the problem will not be solved, I should just trow away it.

  • HARMAN_EEldeHARMAN_EElde Posts: 1,076

    @chiaradani said:
    Hello, I have the same problem as you guys. Has somebody tried to contact the company for an updated driver? If the problem will not be solved, I should just trow away it.

    I will reply to your inquiry in the other thread. You have the Alpha, this is a different device.

  • @HARMAN_EElde said:
    We did test it as working with Mac 10.14 Mojave, so not sure, check the Audio/Midi Setup Application and try a different Frequency and Bitrate. Also if this is with Garageband as the DAW, you may want to try full uninstall and reinstall.

    Thanks for feedback! I will try to change bit rate settings, hope it helps.
    By the way, when I've said system doesn't seen a device - I mean I can't choose it in output or input sound settings, it shows me only default audio. Also, yes, it's mojave OS 10.14. Drivers (both versions) was downloaded from official Lexicon site. So I go keep trying to make it works. Thanks anyway. )

  • Any update on this? My Lexicon Alpha has stopped working with all of my software (GarageBand, Audacity, etc.).

    The device is not that old, and works perfectly fine on my old laptop. If I have to purchase a new interface due to lack of driver support, you can be sure it will be from one of your competitors.

  • HARMAN_EEldeHARMAN_EElde Posts: 1,076

    @mpelzsherman said:
    Any update on this? My Lexicon Alpha has stopped working with all of my software (GarageBand, Audacity, etc.).

    The device is not that old, and works perfectly fine on my old laptop. If I have to purchase a new interface due to lack of driver support, you can be sure it will be from one of your competitors.

    The Alpha does not even have a driver for Mac as it is a Class Compliant device. So there is no software driver it needs to use for it on Mac. It is Plug and Play etc. It is fully tested and working with Catalina 10.15

    I would go into the Audio Midi/Setup Application (not System Preferences>Sound) and check the bitrate and frequency, swap it to something else and then swap it back.

    If you're still have issues please contact tech support (email and phone number is in signature)

  • So sad, I still don’t want to give up such an excellent product, and my IO22 cannot work under Catalina.

  • HARMAN_EEldeHARMAN_EElde Posts: 1,076

    @huangqincan said:
    So sad, I still don’t want to give up such an excellent product, and my IO22 cannot work under Catalina.

    Unfortunately the product has long been discontinued for many years, it will work up to 10.14 Mojave if you want to dual boot

Sign In or Register to comment.