Home Lexicon Products

Lexicon Omega drivers have been replaced by Windows Audio Endpoint drivers.

My - previously working - v2.7 Lexicon Omega drivers have been replaced by Windows Audio Endpoint drivers.

Basic Windows sound works but Cubase and Reaper cannot - now - connect through the Lexicon drivers.

The "Update Drivers" button tells me that "The best drivers for your device are already installed".

The Lexicon is now being treated as a Class-Compliant device that doesn't NEED drivers installed.

I have tried:
Hardware Reset
Uninstalling in Device Manager and reconnecting
Reinstalling the v2.7 drivers, rebooting and reconnecting

Comments

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072

    I personally have tested the Greek Series (Alpha, Lambda, Omega) on Windows 10 latest build 1909 with Reaper, CuBase LE (9 thru 10.5), and S1 latest build (4.6 as of this writing).

    I would recommend uninstalling the Omega Driver with this advanced uninstaller:
    https://www.iobit.com/en/advanceduninstaller.php

    If you are on Windows 10, make sure to disable Driver Signing before reinstalling:

    WINDOWS 10 OPERATING SYSTEM NOTIFICATION
    Windows 10 enforces driver signatures by default. This can be disabled to install drivers that are not digitally signed. Use the following steps to disable driver signature enforcement.

    Click the Start Start menu and select Settings.
    Click Update and Security.
    Click on Recovery.
    Click Restart now under Advanced Startup.
    Click Troubleshoot.
    Click Advanced options.
    Click Startup Settings.
    Click on Restart.
    On the Startup Settings screen press 7 or F7 to disable driver signature enforcement.
    Your computer will restart and you will be able to install non-digitally signed drivers. If you restart your computer again the driver signature enforcement will be re-enabled.

    If it still is trying to install the WDM driver, go into Device Manager and manually select the Omega driver (don't search automatically) and point it to the driver file itself.

    If you're still having problems let me know or contact Tech Support below.

  • elmo7sharp9elmo7sharp9 Posts: 8
    edited April 2020

    Thanks for the rapid response.
    I have tried your suggested fix without success:

    Device Manager "Browse My Computer For Driver Software"...

    Pointed to the v2.7 "OmegaDriverInstaller.exe"

    Next dialog box is "The best drivers have already been installed".

    NOT BEATEN YET...

    Device Manager "Let me pick from a list of available drivers on my computer"...

    Has 2 options: "Audio Endpoint" and "Generic software device".

    NOT WHAT I NEED...

    So, from here, choosing the "Have Disk" option, I navigate to the folder for the v2.7 "OmegaDriverInstaller.exe". The resulting file selector box is looking for "autorun.inf".

    I tried to defeat this by entering . in the filename box, then selecting the v2.7 "OmegaDriverInstaller.exe", but the file selector is hard-coded to only accept "*.inf" files.

    Any clues?

  • Thanks for the rapid response.
    I have tried your suggested fix without success:

    Device Manager "Browse My Computer For Driver Software"...

    Pointed to the v2.7 "OmegaDriverInstaller.exe"

    Next dialog box is "The best drivers have already been installed".

    NOT BEATEN YET...

    Device Manager "Let me pick from a list of available drivers on my computer"...

    Has 2 options: "Audio Endpoint" and "Generic software device".

    NOT WHAT I NEED...

    So, from here, choosing the "Have Disk" option, I navigate to the folder for the v2.7 "OmegaDriverInstaller.exe". The resulting file selector box is looking for "autorun.inf".

    I tried to defeat this by entering the star-dot-star wildcard in the filename box, then selecting the v2.7 "OmegaDriverInstaller.exe", but the file selector is hard-coded to only accept "*.inf" files.

    Any clues?

  • I ran the Device Manager while Windows was in "disable Driver Signing" mode to eliminate as many variables as possible.

    STILL NO SUCCESS...

    The procedure produced the same results as before:
    "The best drivers have already been installed".

    I tried writing my own "autorun.inf" to the same directory as the v2.7 "OmegaDriverInstaller.exe":
    [autorun]
    open=OmegaDriverInstaller.exe
    icon=OmegaDriverInstaller.exe,0
    label=OmegaDriverInstaller

    Choosing the "Have Disk" option, I navigated to the folder for the v2.7 "OmegaDriverInstaller.exe". The resulting file selector box is - again - looking for "autorun.inf", which I pointed to successfully.

    I got a dialog box:
    "The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems."

    The "Driver Details" button in Device Manager continues to report:
    "No driver files are required or have been loaded for this device".

    I have emailed Tech Support with the story so far...

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072

    You need to install the driver and point it to the .inf file, found at this path: C:\Program Files\Lexicon\Omega

    If you're still having issues let me know. I believe I just replied to your email as well

  • Thanks for your continued support.

    C:\Program Files\Lexicon\Omega has no .inf file.

    There's OmegaAsio.dll and an x64 folder, containing the x64 version of the .dll,
    but no .inf file.

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072

    You're correct, I was mistaken, that is the ASIO.dll

    The driver it needs to use is wdma_usb.inf and it is in the C:\Windows\INF folder.

  • elmo7sharp9elmo7sharp9 Posts: 8
    edited April 2020

    Thanks for persisting with this so far.

    I have followed your advice to the letter, taken the "Have Disk" route, navigated to C:\Windows\INF folder in the dialog box and specified wdma_usb.inf

    On coming out of THAT box, it looks like only the INF directory has been specified as a location, but not the specified wdma_usb.inf file.

    The next message is... "Windows has successfully updated your drivers".

    To "Audio Endpoint".

    Back to square one...

    If I enter C:\Windows\INF\wdma_usb.inf into the "Copy manufacturers files from" box, I get an error message, telling me there are no suitable files in that location (Clearly looking for a directory, not a file...).

    I have also tried right-clicking on the wdma_usb.inf file and selecting the "Install" option - which leads nowhere and changes nothing.

    Anything else I can try?

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072

    That's about all the info I have, like I said it's working on my build just fine. Try to update your motherboard chipset drivers, sound card, etc. Also maybe disable the Windows Audio Endpoint from services.msc.

  • elmo7sharp9elmo7sharp9 Posts: 8
    edited April 2020

    Thanks for your efforts.
    Your support for a discontinued product is a rare thing.

    It looks like "You can't get there from HERE...".

    The Lexicon works well in other situations (Even connected to a Raspberry Pi...),
    but I'll need to retire it .

    Oddly, none of my other interfaces have been affected,
    just the one I use the most...

    This is Microsoft's fault.
    Breaking gear by remote control, for no reason...

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072

    Indeed, yeah sometimes it is a matter of incompatibility and that's that. Well if I find any further information I will share this with you!

  • wolfcaswolfcas Posts: 1

    Hi, I'm having same troubles to get my Lexicon Omega work in Windows10 - Cubase.
    I tried all the steps above. Still doesn't work. Would there been a solution in the meantime?

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072

    @wolfcas said:
    Hi, I'm having same troubles to get my Lexicon Omega work in Windows10 - Cubase.
    I tried all the steps above. Still doesn't work. Would there been a solution in the meantime?

    I have tested all of the Greek Series interfaces (Alpha, Lambda, Omega) on Windows 10 latest build 20H2 and they are all working no problem.

  • DavidWBDavidWB Posts: 1

    Hello.
    Omega was working till Friday, and had been installed since Win 8 new PC and through Win10 upgrades.
    I uninstalled it for troubleshooting other issues, but now am unable to install drivers (2.7 version).
    I have Win10 20H2 build, tried disabling driver signing enforcement, running install as administrator, with compatibility settings, combinations of the above, no luck.
    I get the files installed in Program Files, but in device manager Omega is not recognized., and when I try “update driver” pointing to INF files, I get “no good driver files at location”.
    Perhaps manually pointing to driver files? Any registry hacks anyone could suggest?

  • HARMAN_EEldeHARMAN_EElde Posts: 1,072
    edited April 22

    @DavidWB said:
    Hello.
    Omega was working till Friday, and had been installed since Win 8 new PC and through Win10 upgrades.
    I uninstalled it for troubleshooting other issues, but now am unable to install drivers (2.7 version).
    I have Win10 20H2 build, tried disabling driver signing enforcement, running install as administrator, with compatibility settings, combinations of the above, no luck.
    I get the files installed in Program Files, but in device manager Omega is not recognized., and when I try “update driver” pointing to INF files, I get “no good driver files at location”.
    Perhaps manually pointing to driver files? Any registry hacks anyone could suggest?

    I have yet to get my hand on an Omega again since the 20H2 update but yes it seems to have broken things with the Greek series lately for some, but my initial tests I was able to get all of the interfaces working. I did have to disable driver signing enforcement was it

    I'll do what I can in the meantime to see if there is fixes for the people having problems, but not being in the office regularly with the equipment hinders that some. I'll post anything new info wise when I get it and if I happen to roll by the office and do some tests with it to see. Of course if anyone else figures anything out please share it with the rest of us.

Sign In or Register to comment.