Home Soundcraft User Forum Soundcraft Mixing Consoles

Can't upgrade the firmware on my UI16

I have a UI 16 currently running 1.0.5763-ui16 and I want to update it to the latest supported software.
I went to the Soundcraft site and downloaded uiupdate-k-1.0.7548-ui16.zip
I transferred it to a USB stick. When I insert the USB stick into the UI16 I see the "USB INSERTED" message, then nothing. I have:

  • waited up to ten minutes for the firmware update message but it doesn't come
  • tried two different USB sticks
  • tried all four USB ports on the UI16
  • tried having the zip file in the root directory, or in a folder
  • tried rebooting the UI16

None of these has made any difference. What am I doing wrong? The USB ports work for other things, I can play playlists, I can save shows...

OK I am a newbie so it is probably something obvious to the experts out there... help!

Best Answer

  • patrick_keoghpatrick_keogh Posts: 5
    Answer ✓

    I have answered this for myself.

    The mixer will not upgrade from 5763 directly to 7548. You need to install 7048 as an intermediate step. This is not obvious from the Soundcraft instructions. These should be updated to show this requirement. I did the update to 7048 which went as described, and then the update to 7548 which also went as described.


  • How did you find the firmware version that you have installed? When I open the Connected Pa drawer, I see v.1.1.3, but I believe it refers to the application version, not the firmware version of the mixer.

  • Thanks for the screenshot, Patrick! What is this app? Does it have an installer for the MacBook Pro?
  • The app is a browser. In this case Chrome. This is just the standard interface to the Ui16.

Sign In or Register to comment.