Home Soundcraft User Forum Soundcraft Stageboxes

Can't get foot switch to control FX on Ui24R.

After purchasing a non latching foot switch - Boss FS-5U and plugging it in, I can't get the switch to mute FX. The mute FX box is red in settings - global page, but the switch does not mute FX as I expected. I have tried changing the polarity switch on the FS-5U but still no luck. I'm guessing its one of the other settings overriding it perhaps?? Thanks for your help.


  • Options

    I have the same problem with my Ui16. Any suggestions would be greatly appreciated.

  • Options

    I have the same pedal and no issues on my ui16 ,have you tried a different lead,I use a regular good quality guitar lead

  • Options
    just4philjust4phil Posts: 1

    I have the same problem!
    i bought a new non latching foot switch ... my ui24R indicates that the foot switch works (on utility page).
    i configured it to mute FX but nothing happens on press! changing polarity of the switch doesnt change that.

    what are the exact steps to make a footswitch mute the FX? does that work in Main and Aux? do i need subgroups or mute-groups for that? what is the hidden secret....and why is it hidden????

Sign In or Register to comment.