Home Soundcraft Mixing Consoles

Signature MTK12

Hello,
I just purchased this mixer and i found the rtn button a bit limiting i'llexplain:
I use cubase and i want to record a band with 8 mics into the daw.
i'd like to use the metronome in cubase but, in rder to hear it i need to press the RTN button and this disables my "monitoring" through the console without latency whuch i like the option.. i dont want to monitor throgh the box becouse i get latency and if i bring the buffer down i get bad sounds.
is there any solution to this ?

Comments

  • sfdsfd Posts: 4

    Did you found a solution ?

    I've a similar issue. When RTN is enabled on any channel whatever you've plugged (Mic / Line) on that same channel will be disabled.

    Moreover - on my Cubase (8.5) only channel 1 and 2 are active for in- and output.

    And so, if I enable RTN on Chn 1 and 2 I'll get playback from the DAW. However I'm not able to record to the daw from any other channel on the mixer.

    Also - although I get playback from chn 1 and 2 there's no sound from the metronome.

    Th3e driver is installed and all channels are showing up on Windows 10.

    I've not found any guide / tutorial on how to setup Soundcraft Signature 12 MTK on Cubase. Have anyone seen any ?

    Thanks in advance for any help !

Sign In or Register to comment.