USB issue

Signature 22MT US Mixing System Model: 5049563 S/N: 616120DS
Hello, the information above is my mixing console that I need help with. My Soundcraft Signature 22 mtk started acting funny for the first time today. When the USB is connected to my Macbook Pro, something is not acting right within the Lexicon FX and the two FX Returns. When raising the volume of the FX Returns channels the console starts making a constant pop noise continuously every second, like a heart beating, and when I press either one of the PFL buttons ONLY on the FX Return Channels the meter display bounces, hot, up & down with this weird pulsating sound. When I release the PFL buttons the meter stops bouncing though the pulsating sound is still heard. In addition, while this problem is occurring, I’m unable to select any FX from the Lexicon processor, its frozen, and my MacBook Pro is not recognizing the Signature 22 anymore as well. Now, when I disconnect the USB from the mixing console everything seems to go back to normal and I can select FX and the pulsating sound is gone. Once I plug the USB back in exact same issue. I’ve tried restarting, unplugging everything and restarting, rebooting, trying different usb ports on my MAC, different USB cables, etc, even a parameter reset on my MAC. Still same problem. Can you please help ? Thank You, Donny

Best Answer

  • odbmore23odbmore23 Posts: 3
    Accepted Answer

    Hey everyone,
    I was able to get my Soundcraft fixed at an authorized shop for $350.00, though, if your board is still under warranty it will cost you nothing. They had to replace bad compasitors to fix the problem. It all works great again back to normal. Thank god.

    I was in contact with a Harman rep who helped me figure out the fix and where to. If it's of any help, his name & email address is:

    Rafael Ulloa
    [email protected]

    This was his final response after going back and forth on this issue for about a week.

    "Hello Donny,

    I was able to show the video to our techs and they have not seen anything like this. They asked about the basic troubleshooting steps you and I went over and let them know you have already verified all that and everything is up to date.

    Our recommendation is to have it checked by one of our authorized service centers near you. What state do you reside in?

    Here’ the information for the authorized Soundcraft service center in NY; this unit comes with a three year manufacture warranty so make sure you provide them with a copy of your proof of purchase.

    Heavy Electronics and Security
    2075 86th St.
    Brooklyn, NY 11214
    (718) 946-9000

    [email protected]

    Sorry for the inconvenience."

    I hope this helps all of you that has this same frustrating problem.
    Good luck,

    Donny

Answers

  • dunburudunburu Posts: 2

    Hey Donny,

    I'm having a similar issue with my 22Mtk, the interface is not being recognised and making a clicking sound. FX Returns making clicking sound even louder etc.... I notice a few people on these forums with similar problems suggesting these boards have been shipped with a manufacturer's fault.

    Every so often, it makes a connection with my Mac (early 2008 Mac Pro running El Capitan) and works for the day but on restarting the mac/board, the same problem resurfaces

    I've contacted Soundcraft support but not had a reply from the person assisting!

  • Hello,
    I started having a similar problem yesterday, though I have not had the time to do much troubleshooting yet.
    The console was turned on and so was the PC (for at least two days), then suddenly: Every three or four seconds I get a loud POP. I thought it was the PC (Win10) sending garbage through the USB.
    Restarted the PC, and the console; it is the same.
    Unplugging the USB cable makes it stop immediateley, but as soon as the USB cable is plugged in, POP!
    It is not coming from Windows because it happens when the computer is showing the "HP Surestart", long before Windows is even loaded. I tried the other USB ports on the PC and it is the same.
    Anyone else have this problem?
    Any way to fix it?

    Signature 22MTK

Sign In or Register to comment.