Home Soundcraft Mixing Consoles

muting channels on the UI 12

I just got myself a nice little Soundcraft UI 12 and it's taken its first steps outdoor with me yesterday night.

Overall the mixer and me got along well. There is just one thing I found a little strange: the channel mutes. What I'm used to is hitting the mute and the entire channel goes silent. In the UI, the main mix is not getting the sound just as if you'd slide down the fader, but the auxes are still getting the signal. Unless you proceed to the aux mixes and mute the channel there as well.

Does anybody else find it contradictory that the mute groups actually mute all the outputs of one channel instead of only the main mix?

Comments

  • For reference. I found the answer. In the settings > Global, there is a switch "aux send mute inheritance" which is set to OFF by default. Flip it to ON and the aux chan will be greyed out when the channel is muted from the main mix screen.

    Also, the option below it called "global aux send point" is set to "post processing" on my device, which is contrary to how a regular analogue console works at least (non EQ'ed pre fader auxes).

    Happy mixing, (at least I am!)
    F.

Sign In or Register to comment.