Home Soundcraft User Forum Soundcraft Mixing Consoles

Soundcraft mtk 12 channel - Headphone monitoring

Hello guys,

How do I hear only on my headphones and not on the main speakers? The main output is coming via 11/12 USB return. If I engage PFL button, I can hear only on headphone but it's a mono signal.


  • Options

    Use a group out for your headphones independent of the master fader with a breakout cable.. https://www.ebay.ca/i/302566903917?

  • Options

    Hi Supadupa555,
    I also fought with my MTK22 on this issue, and spent a lot of time. You get the Stereo Signal on the Headphone under following conditions:

    • No PFL / AFL switch pressed
    • Master Volume Fader regulates your Headphone Volume

    (I for example had only one PFL switch pressed and I got only
    a Mono Signal in my Headphone)

    Have fun!

Sign In or Register to comment.