Home Soundcraft Mixing Consoles

Brand New 22 MTK USB problems

Due to the pandemic my church has switch to streaming and i was asked to handle that. As an IT professional of 25+ years, I was excited to take on this task. I recommended the Signature 22 MTK. They took my advice w/o question. Bought it new, no refurb. The unit is about 3 weeks old from unboxing. Brand new computer built specifically for streaming. I am using channels 1, 3, 5 for mics. Channel 21/22 as the USB return. Computer OS is Windows 10 Pro. Streaming software OBS. Latest updates on Windows.
Latest version of OBS. Latest drivers on all hardware. Multichannel driver version 3.20 as found here www.soundcraft.com/en/software

Mics into the computer work fine. Sound out to channel 21/22 works fine. But not at the same time. It's random. When the mics work the usb return doesn't. When the usb return works the mic don't. Occasionally i'll here a very faint click and it will switch over. For example sound will be coming out through the return and i'll here a slight click and then the mics will start working but the usb return stops immediately.

Rebooting does not help. It is also random. one reboot, mics will work, another reboot, usb return works.

I called Soundcraft tech support and they recommended having the Vendor send a replacement since the device is so young. I'm hoping that as I'm waiting, someone here will have experienced this before or have suggestions.

Thanks,
revd13

Comments

  • revd13revd13 Posts: 2

    Figures this forum is dead. can't expect help from souncraft i guess. Received new device. New device worked ONCE and then started doing the same thing as the old device. piece of trash hardware and company. phone support is trash too.

  • bobslaunbobslaun Posts: 2

    Too bad, I cant get my channels from 3-22 to send a signal to the usb to the daw, only the first 2 channels will work, I must be doing something wrong

  • The Manual to this device is abysmal at best. I just bought the same mixer an I am really scratching my head. Where do I start, it seems like it's an ongoing experiment to find out how to use it. I really feel like i am out of my depth with this POS. But I know it will come good, but I need help.

  • HARMAN_TderHARMAN_Tder Posts: 184

    What do you need help with? Not clear on your post

    @Interplain said:
    The Manual to this device is abysmal at best. I just bought the same mixer an I am really scratching my head. Where do I start, it seems like it's an ongoing experiment to find out how to use it. I really feel like i am out of my depth with this POS. But I know it will come good, but I need help.

  • JMixSonJMixSon Posts: 5

    @HARMAN_Tder said:
    What do you need help with? Not clear on your post

    Although all of the Ins & Outs of the Signature 22MTK are available to select from in OBS Studio, OBS is not hearing them.
    I've spent countless hours trying to figure out how this can be, from both the Soundcraft side and the OBS end, including Windows 10 settings that are obviously related to USB audio.

    I've tried assigning Master L/R to the #1 (and also #2 w/ Mono checked and unchecked) track of OBS.
    This seems reasonable because OBS offers a means to adjust input gain; not every capture application does.

    When that didn't work, I assigned MTK Outs 5 & 6 to OBS tracks #1 and #2 - even to tracks to tracks #5 and #6.
    These are my sound module channels on the MTK. I have other channels to send, but if these won't work, then there's no point.

    So, as a test (but hopefully not a permanent config), I ran a cable from MTK's Group 4 out to input 1 of my Behringer U-Phoria UMC404HD.
    This worked the very first time. OBS input meters lit up after assigning the Behringer as the audio input device and very little else in the way of settings.

    I'm not a code programmer, but it appears to me that the problem is in the Soundcraft driver.
    This page says the latest driver was uploaded in March of 2019:
    https://www.soundcraft.com/en/support_downloads
    Maybe I missed a driver update, and this would solve the mystery!!

    I downloaded this "new" driver and compared the file info with what I had installed back in November 2018.
    To my dismay, the file names and version designations are the same:
    Soundcraft_Multi-channelUSBAudio_DriverSetup_v3.20.0.
    And the executable is dated** 9/8/2015**.

    2015?

    Thanks for listening. It would be great to hear back with good news.

Sign In or Register to comment.