Home Soundcraft User Forum Soundcraft Mixing Consoles

Si Impact: after assigning main input channels to L/R out, there is no meter indications, no output

Reset to factory using reset in menu. Si Impact: after assigning main input channels to L/R out, there is no meter indications and no output. Help - Anybody? What do I check?


  • Probably best to contact tech support but there's a lot of info missing here in terms of helping to troubleshoot. For example: Do you have input meters? Do you have audio in headphones with PFL solo of channel? Is Master Fader up and at unity ? Are channels turned on? No Mute Groups or VCAs assigned? etc...

  • I am an experienced live sound mixer operator. The Impact is new to me though I have many years experience with digital. Another person installed and set up this mixer, amazingly complex, using Sub Mix for main and monitor outputs using a mini stagebox. I am trying to set up the mixer more standard, with the main going out the mains instead of a aux. I reset everything, plugged in a mic, got signal on the channel, pressed both the mono and L/R buttons, turned up the main slider - no meter indication, no output. Thought that the reason the mixer was setup wrong is because the main output does not work. Thought someone with setup experience could help me determine if the main output is broke and needs be repaired or there is something simple like the mini stagebox is not setup correctly. I will be at the church this morning to disconnect the stagebox and see if the mixer works right.

  • Just saw your response so hopefully you did contact tech support. Regardless- though too late to do any good - I would make sure that there are No inputs assigned to VCAs. Make sure that the insert point on the main outputs isn't inserted with nothing patched. It would be unusual for the output only not to work so my guess is this will end up being finger problems. Since you had input meters- it is likely PFL/Solo on the channel did get audio to appear in phones.

    Otherwise assignment as you described to L/R should work and with LR fader up and turned On should get you output or at least inputs on the meter. Also make sure that the rotary monitor control and master fader aren't swapped. This is a setting in the menu and is pretty obvious as the master fader will glow RED as a warning.

Sign In or Register to comment.