Home Soundcraft User Forum Soundcraft Mixing Consoles

MacBook Pro Won't Recognize Soundcraft MADI USB Combo

I currently use our Soundcraft Si Impact board with the Soundcraft MADI USB Combo interface to connect to my MacBook Air and Logic Pro X. MacBook Air (13-inch, Early 2015) is running Big Sur MacOS. Interface is connected with with standard USB cable (A/B type). All this works just fine.

I recently acquired a MacBook Pro 2021 model. Also running Big Sur MacOS. This laptop does not support the older USB connector type (A/B) so I have tried to connect the Si board using a USB adapter (USB to USB-C) but have inconsistent results. Usually, it does not show up in Input Device in Logic Pro X (or on the Mac)

However, a few times I do see the Soundcraft MADI USB Combo interface listed. When its available, I am only able to see 2 Inputs and neither seem to work (no activity on input monitoring/meter).

I can still put the same USB cable into the old MacBook Air and it works fine.

I'm concerned there is a compatibility issue, perhaps with the adapter or difference in USB 2.0 vs. 3.0 etc...

Has anyone had similar results or have any suggestion?

Comments

  • HARMAN_TderHARMAN_Tder Posts: 184

    Currently researching and will let you know. Is this laptop using Apple's M1 Chip?

  • billsneverbillsnever Posts: 7
    I don’t think so. Processor is 2.3 GHz 8-Core Intel Core i9
  • HARMAN_TderHARMAN_Tder Posts: 184

    Odd.... then i have no idea. I'll discuss internally and see if we have any theories. Only thing i can think of is some sort of change in Mac Core Audio but it doensn't make any sense.

  • billsneverbillsnever Posts: 7

    According to the Soundcraft MADI-USB Combo product documentation, "the USB port on the MADI-USB combo card is the ‘B type’ connector (the standard type for peripheral devices). USB host devices use the rectangular ‘A type’ connector. As such, a ‘Type A to type B’ USB cable is required." However, the MacBook Pro only supports USB-C type. Apple specifications it shows that the MacBook Pro has 4 Thunderbolt 3 (USB-C) ports with support for USB 3.1 Gen 2 (up to 10Gb/s).

    My only theory at this point is that I have some USB compatibility issue. I have tried with 2 USB adapters with no success, but perhaps I need some different USB cable (B type to C type), or the MacBook Pro USB 3.0 is not reverse compatible with USB version supported by Soundcraft USB interface?

  • billsneverbillsnever Posts: 7

    Some additional research...

    • MacBook Air (Early 2015) supports USB 3.0 with Type-A USB ports
    • MacBook Pro (2021) supports for USB 3.1 Gen 2 with Type-C USB ports
    • Soundcraft MADI-USB Combo interface uses Type-B connector. Not sure what version of USB it supports.

    According to data on Kington website, "When it comes to USB 3.1 Gen 1 and Gen 2, the only difference is speed and they're backwards compatible with USB 3.0 and USB 2.0."

    While this is in context of memory sticks, it seems that USB compatibility should not be an issue. Only theory remaining for me is the USB adapters (both Apple products) are causing some issue. Seems unlikely and perhaps the USB issue is just a rabbit hole.

    As one last option, I was looking for a USB Type-B to Type-C cable so I can avoid any adapter. I came across something on DataPro's site indicating that USB 3.1 Gen 2 required "Type-B Superspeed" connector. See https://www.datapro.net/techinfo/usb_info.html

    I will investigate this further but might take some time to acquire a cable. Is there any way you can test the Soundraft MADI-USB Combo with USB 3.1 Gen 2 host?

  • HARMAN_TderHARMAN_Tder Posts: 184

    The initial guess is an issue with the adpater. The product manager is going to do some testing and hopefully we'll have some word back next week.

  • billsneverbillsnever Posts: 7

    I have ordered a USB 2.0 B-type to C-type cable to avoid any adapter. I should have it later this week to test again.
    Any feedback from product manager?

  • HARMAN_TderHARMAN_Tder Posts: 184

    No response yet.. he was supposed to test and get back to me. Just because there haven't been a ton of other reports like this I think it has to be the adapter. We also are looking a changes in Mac Core Audio Driver with the new M1 chip but this wouldn't pertain to your issue. Perhaps some other change in Big Sur but again believe we would be besieged with people contacting us about the issue.

  • billsneverbillsnever Posts: 7

    Out of curiosity, do you have recommendations to optimally connect Soundcraft Si Impact besides the MADI/USB Combo interface? Any options that would take advantage of MacBook using USB 3.1 Gen 2?

  • billsneverbillsnever Posts: 7

    SOLVED! New USB cable (USB 2.0 B-Type to C-Type) works.

  • HARMAN_TderHARMAN_Tder Posts: 184

    Good news- as you had me sort of stumped. I was hoping it would be that simple

Sign In or Register to comment.