Home Soundcraft User Forum Soundcraft Mixing Consoles

Notepad 12FX not recognized by Windows 10 after attempting to install control center & firmware.

I recently tried to install the Soundcraft Control Center software on Windows 10 for my Notepad 12FX. After installation, I opened the firmware program, it asked if I wanted to update my device from firmware v1.09 to v1.09. I clearly didn't need an update but I clicked "yes" for absolutely no reason other than it was a reflex. The installation halted about 3/4 of the way through and then failed. I then received a notification from Windows (bottom right of my screen) saying that my device wasn't recognized.

It was then that I realized I done goofed.

I went into the control center and the program said no devices were recognized. Realizing I might've screwed up, I uninstalled all of the software, including the Harman folders in my file explorer. I restarted my system and reinstalled all the software. This time around, not even the firmware program would recognize my notepad. In fact, even during installation (which I repeated about another 5 times), I would get a prompt asking me to disconnect and reconnect my device before finishing the installation, which I did each time. Each time, I received the same damn notification at the bottom right of my screen, telling me that my device wasn't recognized.

Additionally, although my mixer still processes the audio signals from all of my instruments, the FX panel doesn't work whatsoever, it's effectively bricked. I've searched online for a couple of hours and nothing seems to successfully address this issue. I'm now stuck with a unit that won't be recognized by either Windows or the Harman software and that has no functioning FX.

I dug around a bit more and found tutorials on modifying the drivers manually and working around digitally signed drivers. Nothing has worked. I'm at a brick wall and don't know where to go from here. I'd like to call customer support but they're closed until Monday. I just wanted to control 4 tracks individually in my daw, now I'm stuck with this nonsense. It really shouldn't be such a big problem, but I'm seeing that it has been for around 2 years now with no clear-cut solution in sight.

If anyone's got some insight, please help a brother out lol.


  • JobJob Posts: 1

    Just got one, and immediately same problem.
    Any progress?

  • VoidofSaladsVoidofSalads Posts: 2
    edited August 2022

    @Job said:
    Just got one, and immediately same problem.
    Any progress?

    Unfortunately, I have not made any progress. I've got a few other methods of recording that I've been working at in the meantime (and, surprise, having issues there too! lol..ugh). Part of the problem is that I'm typically working when Harman is open. I'll have to take some time out my workday next week and reach out to them. I have a bad feeling I'll need a replacement but let's see..

    If you make any progress, I beg thee to let me know if you've found a solution lol. Best of luck :)

Sign In or Register to comment.