crown xls 1502 remote trigger - two big issues

I have just purchased the 3 way phoenix connector and with the aid of a tiny 12V dpst relay can successfully trigger itwith my home receiver.

However, I haven't permanently attached the relay yet as there appears to be two very big issues with how the amp operates when it is turned off(terminal one and two on the aux port are shorted together)

I have found it doesn't actually switch the amp off as claimed and it still uses considerable electricity, this was noticed that even when the amp was in sleep mode for several hours the front of the amp was very warm to the touch. It appears that all that happens is the amp is put into mute mode.

The other issue is that when it goes into sleep mode, the two bright blue leds on the front panel flash to a very distracting level, I have turned off all the lighting in the menu, but this doesn't appear to work in the sleep mode, it would be good to know how to bypass the leds, and indeed what is the issue that the amp is not actually being remotely powered properly.

Comments

  • addyaddy Posts: 5

    I have received advice from crown tech, that there is nothing wrong with my amp and that it will use a small amount of power in standby due to the main power supply still being used/operative. I did not get any clarification of what a small amount of power is.(I'm sure the exact amount is known)
    I have measured that the amp is between 8-10 C above ambient when in standby mode, and doesn't actually measure any different to when the amp is at idle.
    My estimate would be that in sleep mode the power draw is in the region of 10 W. **** Hence its not really appropriate to describe this amp as having a sleep or standby mode.****

    I have discovered a 3 problem with the unit, significant rf interference on the AM radio band. I can not operate AM radio on my receiver(even with the aerial located metres away) without significant whistling whilst the crown is switched on

Sign In or Register to comment.