PCM96 with MacOs 10.13.6

Hi there,

nobody here....?

I would just like to ask if the PCM96 can still be used as a PlugIn under MacOs High Sierra. When I try to install the latest software Version 3.5.3.6 the Mac warns me that the software I am installing is old and can be dangerous for my system.

Has anybody installed this software under High Sierra or is there another way of using the device with a Mac?

Thank you, Micki

Sign In or Register to comment.