Soundcraft Signature 22 mtk USB problem... PLEASE HELP!

Signature 22MT US Mixing System Model: 5049563 S/N: 616120DS
Hello, the information above is my mixing console that I need help with. My Soundcraft Signature 22 mtk started acting funny for the first time today. When the USB is connected to my Macbook Pro, something is not acting right within the Lexicon FX and the two FX Returns. When raising the volume of the FX Returns channels the console starts making a constant pop noise continuously every second, like a heart beating, and when I press either one of the PFL buttons ONLY on the FX Return Channels the meter display bounces, hot, up & down with this weird pulsating sound. When I release the PFL buttons the meter stops bouncing though the pulsating sound is still heard. In addition, while this problem is occurring, I’m unable to select any FX from the Lexicon processor, its frozen, and my MacBook Pro is not recognizing the Signature 22 anymore as well. Now, when I disconnect the USB from the mixing console everything seems to go back to normal and I can select FX and the pulsating sound is gone. Once I plug the USB back in exact same issue. I’ve tried restarting, unplugging everything and restarting, rebooting, trying different usb ports on my MAC, different USB cables, etc, even a parameter reset on my MAC. Still same problem. Can you please help ? Thank You, Donny

Comments

  • LefouLefou Posts: 5

    Hello,
    I started having a similar problem yesterday, though I have not had the time to do much troubleshooting yet.
    The console was turned on and so was the PC (for at least two days), then suddenly: Every three or four seconds I get a loud POP. I thought it was the PC (Win10) sending garbage through the USB.
    Restarted the PC, and the console; it is the same.
    Unplugging the USB cable makes it stop immediateley, but as soon as the USB cable is plugged in, POP!
    It is not coming from Windows because it happens when the computer is showing the "HP Surestart", long before Windows is even loaded. I tried the other USB ports on the PC and it is the same.
    Anyone else have this problem?
    Any way to fix it?
    I will post anything new after I do more troubleshooting.
    Signature 22MTK

  • IceboundIcebound Posts: 1
    edited October 9

    Same problem here. Lout pops from FX return channel. And my mac can't see this mixer as Interface anymore. Also headphones signal sometimes changing from stereo to mono.. No idea what to do. Seems like electronics in this fella is weakest part. Just can't use it any more. Maybe someday Soundcraft realise that they need to release firmware updates from time to time for their products

Sign In or Register to comment.