Home Soundcraft User Forum Soundcraft Mixing Consoles

Soundcraft Signature 22 mtk USB problem... PLEASE HELP!

2»

Comments

  • GrailseyGrailsey Posts: 6
    edited December 2021

    Hi, I have a similar problem – I have a new MacBook Pro M1 Max for my studio and am experiencing problems connecting my MTK 22 via an Apple USB-C to USB-A adaptor and a USB-A to USB-B cable. The MTK constantly resets, making it unusable. I've tested it on a Mac mini M1 and the MTK works fine when connected to the USB-A port, but exhibits the same problems connecting to the USB-C port with the Apple adapter. Additionally it will not work via any other USB-C to USB adapter, or from the USB-A ports on the back of my Apple Cinema Display. I've ordered a high quality 'AV' standard USB-C to USB-B cable to see if that makes any difference, but fear this is a fool's errand. I did have it working fine via USB-C on my previous (2017) MacBook Pro, though only on one particular port. Any help or guidance much appreciated.

    Thank you!

  • Just to note, the cable I bought made no difference whatsoever.
    https://www.futureshop.co.uk/audioquest-forest-usb-type-a-to-usb-type-c-data-cable

  • I've also tried this powered USB-C, as I read that M1 Macs may not deliver the same power over USB-C as previous Macs. Doesn't play at all.

    https://www.amazon.co.uk/gp/product/B098B7QZNL :(

  • The issue still persists on Monterey macOS 12.1 if anyone's interested or has any guidance to offer.
    Thanks!

  • I tried to buy a Signature 22 MtK and found they were backordered for at least 6 months. I decided to buy one on Ebay. S/N 61838250. As soon as I plgged it in I got the Clicking sound that we now know is a Capaciter problem in the Pwer Supply. I contacted the Harmon authorized support near me and spoke to a sales person and he took my information. I emails the same group hoping to get them to purchase for me and install the**5071678-02.V - Signature PSU Assembly Model 2019. They have not called me and no one on the internet has this product.

    Since my LX7ii died in November and I re-invested in Soundcraft with the next board I expected good quality, but it seems the very design of the product is faulty and all units should be recalled to fix a now known problem.

    Can anyone identify how I can even pay for a replacement at this point?

    Jeffrey Strassman

  • LefouLefou Posts: 7
    Hello Jeffery Strassman,

    It is an easy fix if you know how to use a soldering iron.
    If not, you could take it to an electronics repair shop.

    If you would like, I could sell you my board (22mtk). The PS capacitors have been replaced.

    Steve
  • GrailseyGrailsey Posts: 6

    Still the same on macOS 12.2 too. I did speak with Apple about this in December and they said their engineers were aware of issues with audio and USB-C. Fingers x'd for a 12.3 fix, but not holding my breath.

    @Grailsey said:
    The issue still persists on Monterey macOS 12.1 if anyone's interested or has any guidance to offer.
    Thanks!

  • My Signature MTK12 has just had the same problem on my Macbook. I've tried taking out the hub and connecting directly to the laptop with no luck. Who has had success with the capacitor change?
    And...is it time to organise a class action??

  • sharrissharris Posts: 1

    It is ridiculous that there are so many problems with the Signature MTK series. I have 2 that had/have dead channels and they are were under a year old with low, easy usage. There is clearly bad parts/design flaws with these boards. I hope that this company plans on fixing this issue and replacing these crap boards or I'll never buy a Harman product for the rest of my life.

  • nominalnominal Posts: 1

    I had this issue as well on my Signature 12 (two weeks after my warranty expired, lmao) and can confirm that the capacitor fix took care of it. As the previous posters mentioned, the problem in question is easily recognizable by a regular popping - I thought it was a kick drum at first. If you unplug the USB cable going into your PC, it will likely go away and the rest of the mixer may still be usable. But since I use this mixer as a my primary audio interface, I needed it fixed.

    I ordered the caps on Saturday night, they showed up this afternoon, and then by Monday evening I had a working mixer again for about $0.20 worth of parts. Well, I mean, I bought a bag of 50 caps so it was more like five bucks all told, but hey, now my mixer can conk out 24 more times and I'll still be good. Also, I did possibly the worst soldering job in my life on these and it STILL worked (the solder they use on the board wants about as much heat as my iron could kick out before it loosened, and I had a hard time getting the board clean). I think even someone without much electronics experience could probably handle this repair, just make sure your caps are oriented correctly, which should be easy if you use the other capacitors on the board as an example. If you are nervous about your soldering skills there are some soldering trainer project kits you can grab on Amazon for pretty cheap while you order your capacitors and that should help you get a hang of things.

    One thing I noticed is that a few of the previous posts seemed to refer to one of the caps by an incorrect placement number on the board (C113). C113 is an smt cap - that is not the one you want. Unfortunately I didn't get a pic of the correct number before I put the mixer back together, but just refer to the image someone posted previously with the arrows pointing to the correct pair of capacitors and that should get you straightened out. I believe if you search youtube for "SOUNDCRAFT POWER SUPPLY CAPACITOR REPLACEMENT" there is also a youtube video that may give you some more views of the correct caps to replace, although the youtube video doesn't go into very fine detail.

    Thank you so much to the folks who posted about this fix, I thought I was going to have to replace a mixer there for minute! I owe you a beer.

  • peterschellpeterschell Posts: 2
    edited April 14

    I am a Soundcraft signature Mkt22 USB survivor, saved by the CAPACITOR FIX. It works.

    Same story: great Mkt22 reviews, bought it, loved it, USB stopped working out of the blue, fixed under warranty (cost $200 shipping), power stopped suddenly a few months ago (3 years post-purchase), local guy changed PSU (cost $400), power back but intermittent, funky USB + 1 FX channel/panel not working + weird interference with computer audio (need to disable/enable soundcraft channels in sound panel to get computer audio to work). Insert screams of frustration. Add hours of trying to understand/change things out, etc.

    Was about to throw the Mkt22 onto the highway and buy a Tascam 24 but read this forum and watched the famous capacitor fix video.

    Found a local guy who very nicely provided 4 x 100uL x 100V capacitors for free. Took a deep breath and did the surgery with a soldering iron (never touched innards of a mixer before). 1-hour later, presto... MKT22 back in action and working like a charm (maybe its my ears singing but it sounds better/richer). It's a great board for me when working (primarily home recording).

    To the guys who did the video fix... ten thousand thank yous!! As well, big thanks to those on this board who added their experience and advice on the capacitor/USB fix. A little nerve wracking to do the first time, but once done, super easy.

  • I started having the USB popping/clicking problem and it turns out my mac mini didn't like having the new powered USB hub I installed on one of the USB busses of the mac, as soon as I unplugged it and restarted my mac the popping and usb clicking stopped straight away.. ugh anyways now I have a powered hub I can't use that I run all my USB midi for various synths that have plug ins librarians etc..

  • FiddlestickzFiddlestickz Posts: 3
    edited June 20

    Aaaaaand it came back again, so I must have to change the caps it looks like...damn this sucks hard. Anyone point me in the direction of where to buy the caps..?

  • @Fiddlestickz said:
    Aaaaaand it came back again, so I must have to change the caps it looks like...damn this sucks hard. Anyone point me in the direction of where to buy the caps..?

    Well it turns out my repair guy had some 35v caps and we took out the 2 dodgy bulging caps, soldered the new ones in and the mixer works perfectly now, hopefully for many more years to come.

  • LscottkLscottk Posts: 2

    I had this problem on my MTK22 - USB attempting to connect, then dropping then attempting to connect, repeating the cycle over and over. It turns out that this issue was due to a failed power supply. The solution was to have the mixer serviced and the power supply replaced. I had my board serviced at Sound West Tacoma, which is located in Tacoma, Washington (USA). Due to supply chain issues it took months to get the required replacement part. Once they received the part the repair only took a few days.

    Apparently this part failure is due to leaving the mixer on 24/7. I was shamed by someone at Soundcraft Technical support, who told me that I should be using a power strip to turn the mixer on and off. It was not a positive support experience. I have mentioned this many times on other forums - that Soundcraft expects the consumer to compensate for their poor design choice of not including a power switch on the board. I also commented how there is no mention in the manual or online that the board will fail if it is left on continuously. The fellow at Sound West told me that he has an older Soundcraft board that he has left on continuously in his studio for years with no issues due to heat buildup and failing power supply. Ironically, his board has a built in power switch.

    The tech that I spoke to at Soundcraft was incredibly condescending. A very negative experience that has turned me off from purchasing Soundcraft products in the future. Not to mention that my $1000 board required a few hundred dollar repair due to poor design and documentation from the manufacturer. Too bad about this as Soundcraft used to be excellent quality. Live and learn, I guess.

    I wish that I had seen this thread before today. I would have attempted to replace the caps myself and saved some money. Thanks to all for sharing this information.

  • Hi, I'm still seeing the same problems with the MTK 22 over USB-C on macOS 12.5.1. I've tried this on both a 2016 MacBook Pro and a 2021 MacBook Pro M1 Max. It worked fine on the 2016 MacBook Pro before upgrading to Monterey.
    It's fine on an M1 Mac mini running Monterey when connecting directly to a USB-A port.

    Here's a sample of the errors I get on the 2021 MacBook Pro M1 Max:

    • Process coreaudiod.640 TurnedOff PreventUserIdleSystemSleep "com.apple.audio.AppleUSBAudioEngine:Soundcraft:Soundcraft Signature 22 MTK:100000:1,2.context.preventuseridlesleep" age:00:11:57 id:4295002591 [System: PrevIdle DeclUser kDisp]
    • HALS_IOContext_Legacy_Impl::IOThreadEntry: 268 AppleUSBAudioEngine:Soundcraft:Soundcraft Signature 22 MTK:100000:1,2 (AppleUSBAudioEngine:Soundcraft:Soundcraft Signature 22 MTK:100000:1,2): stopping with error 0
    • HALS_IOContext_Legacy_Impl::IOThreadEntry: 268 AppleUSBAudioEngine:Soundcraft:Soundcraft Signature 22 MTK:100000:1,2 (AppleUSBAudioEngine:Soundcraft:Soundcraft Signature 22 MTK:100000:1,2): starting

    As previously mentioned, I spoke to an Apple Engineer about this at the end of 2021 and was told it was a known error with USB-C that would be fixed in a coming update. Well, not yet! But I've not been able much in the way of other complaints with Monterey / USB-C audio issues more generally. Would anyone suggest I try the MTK PSU fix? I'm in the UK, and of course my MTK is long out of warranty now.

    Any help gratefully received. Thanks :)

Sign In or Register to comment.