Home Soundcraft User Forum Soundcraft Mixing Consoles

Signature 22 MTK USB interface is not being recognaised anymore

I bought a Signature 22 MTK on 06/07/2019 and it was working perfectly all these days. But, today when I turned it on, its usb interface is not been reading by my PC DELL Win 10 anymore. Please help, someone knows whats is happening? Thanks.


  • dunburudunburu Posts: 4

    Hey Ciro,

    I'm having the same problem but on a Mac. My 22MTK has stopped being recognised by my Mac and is making a clicking sound through the speakers when connected via USB, which I'm guessing is timecode signaL? It sometimes comes back to life and makes a connection but hasn't done so for a few days now. I contacted Soundcraft Support and the person dealing with my case has stopped replying to the email thread!

    Have you had any success in resolving the problem or getting help from Soundcraft?

  • Hello friends...
    Same problem with 12MTK... Mixer not recognized by PC... Any solutions...?

  • FoggyFoggy Posts: 2

    Having same problem with 22 MTK. Spoke to tech support, said it was card in the box, ordered and installed, did not fix. 3 year old door stop? Sounds like a common problem with these. Being that dunburu has same problem on a Mac, doesn't sound like windows problem.

  • just received my Replacement 22mtk and it still won't record into Cubase Pro10, the firmware won't even upgrade as its saying its not connected!! is this a problem with Mac? or the MTK anyone??

  • I'm having the same issue with a 12MTK and iMac. Just emailed tech support so hoping for a positive response. It seems though that this might be a hardware failure. Anybody had this successfully repaired?

  • I just started having the POPs happen yesterday. I am on Windows 10.
    I did not have the time to do much troubleshooting but I should by the weekend. Hopefully it is not the end of the console's life...
    Anyone have anyhting else to add?
    Any responses since july?
    Signature 22MTK

  • macpro tower and mtk 22- last night it was working fine, today everything works except the USB interface. It's not connecting with tower or my laptop...

  • I just got an MTK12 and it's not being recognized by Windows. I've tried reinstalling, updating drivers, restarting my PC etc. but nothing works. Any solutions?

  • MTK22MTK22 Posts: 2

    I have an MTK22 for 6 months. Now I can't find my 22 channels. It only detects Outputs 1/2...
    Reinstalled the USB interface but no difference.

    For people with not recognizing in general, I had this issue multiple times. Had to reboot or use different usb cables and usb ports, but seem to be stable now. (only I can find 2 instead of 22 channels :neutral: )

  • I'm freaking out as my Signature 22 MTK is no longer being recognized like everyone else here! Noticed the pulsating overloaded signals on FX Return 1 and 2 as well. Need Help please! Dell 8700 PC. Windows 10 Home. Vers 1903.

  • Has anyone in this thread contacted HARMAN Pro Tech Support to troubleshoot this issue?

  • Hi Rob,

    I tried that but never received an answer. I meanwhile contacted the german distributor
    AUDIO PRO HEILBRONN Elektroakustik GmbH.

    They were very helpful and friendly! I am a happy owner again.

  • Electro_Lurch - what did the german distributor do? Replace the mixer or provide a fix? If a fix, can you post to this board?

    Yesterday (Nov 23) my Signature Mkt22 started getting the same POP when connected via USB. Now, my computer no longer recognizes the mixer (happened after driver re-install). I have tried everything listed above: different USB ports (2.0, 3.0), different USB cables, reboots, mkt22 driver reinstalls). USB ports and cables all good. Very discouraging. I will try Tech support but doesn't sound like they are helpful.

    Anyone have anything that worked?

  • TommyVTommyV Posts: 2

    I Just was experiencing the same Issue after a year of use with the MTK signature 22, all of a sudden my matchbook pro would not recognize the unit. I have a expensive $50 USB cable as well. I had a brand new still in the package USB cable from one of my printers that I thought I would try it and boom it instantly recognizes the SoundCraft MTK Signature 22. Im wondering if powering on and off may take a toll on these cables. Will see how long this one last.

  • I'm having the same problem. The past few days if I let the board warm up for a while / unplug/replug USB cable / restart computer, it would finally connect. Today it's taking even longer - I finally just plugged in my Focusrite Scarlett for now and plugged the monitor outs to the the MTK22 because I don't want to have to deal with this every day (for all the days I don't record music). Unfortunately, I can't record as many tracks with that, and I already have everything plugged into the MTK22. When I go to Device Manager, the board will keep disconnecting/reconnecting. If the speakers are on, I get the pulsing sound (As I recall from before, I think the pulsing happens at the same time as the board reconnecting - but I have been keeping the speakers off lately until I get a good connection so as to not ruin the speakers). It seems like the USB cards just die after a certain number of years, and maybe we're all running into that lifespan now. It would be nice to know how/where to go to get it replaced...

  • I am contacting support - hopefully they can guide me on how to get it fixed.

  • awiawi Posts: 6

    scroll down at above link to see the usb power rail problem posted by gelabs on july 8, 2018. two capacitors go bad. $2.00 repair. if you can solder.

  • RootsyRootsy Posts: 7

    Hi, I am having problems with my Soundcraft Signature 12 MTK mixer.
    The driver which I downloaded from the Soundcraft site does not seem to work correctly with Windows 10.
    The choice of outputs does not show in the Windows 10 control panel and the default outputs are on 2 mono tracks, 1 and 2 with no option to select a stereo track.
    The driver works fine with Windows 7 where all the outputs are shown in the control panel.
    Has anyone else had this problem and can anyone suggest a solution?

  • dadsodadadsoda Posts: 3

    This just happened to me after owning it for two years.. Getting a constant reconnecting sound from windows but the device is not recognized in the soundcraft control panel.


    I have only had my 12 MTK for a few days but ran into this same issue with the USB unrecognized device error.
    Re-installed the driver using the process too toggle off the unsigned driver security. That did not work though the driver seemed to install and I unplugged/re-plugged in the USB cable to my laptop. I tried copying the driver executable outside of the .zip file and no difference. I tried uninstalling Focusrite drivers and nope, no difference.

    Here's what worked:
    1) Powering off the 12 MTK (needs an inline power switch). Wait 5-10 seconds and plug power back in.
    2) In Windows 10 Sound Settings, insure that Output device has Line Out 11/12 (Soundcraft Signature Series 12 MTK) is selected.
    3)In Windows 10 Sound Settings, insure that Input device has Mic/Line in 11/12 (Soundcraft Signature Series 12 MTK) is selected.

    After that is done, the monitor speakers (Group 1-2 faders) and front of house speakers (Master fader) all worked as they should.

    I am going to find an inline power switch toggle in a PC cable for the 12 MTK that has the toggle switch at least 8 inches from the male end that goes in the 12 MTK and that cable will have a female end I can just plug the existing male end into.

    I hope this helps.

Sign In or Register to comment.