Home Soundcraft Mixing Consoles

Soundcraft Signature 22 mtk USB problem... PLEASE HELP!

Signature 22MT US Mixing System Model: 5049563 S/N: 616120DS
Hello, the information above is my mixing console that I need help with. My Soundcraft Signature 22 mtk started acting funny for the first time today. When the USB is connected to my Macbook Pro, something is not acting right within the Lexicon FX and the two FX Returns. When raising the volume of the FX Returns channels the console starts making a constant pop noise continuously every second, like a heart beating, and when I press either one of the PFL buttons ONLY on the FX Return Channels the meter display bounces, hot, up & down with this weird pulsating sound. When I release the PFL buttons the meter stops bouncing though the pulsating sound is still heard. In addition, while this problem is occurring, I’m unable to select any FX from the Lexicon processor, its frozen, and my MacBook Pro is not recognizing the Signature 22 anymore as well. Now, when I disconnect the USB from the mixing console everything seems to go back to normal and I can select FX and the pulsating sound is gone. Once I plug the USB back in exact same issue. I’ve tried restarting, unplugging everything and restarting, rebooting, trying different usb ports on my MAC, different USB cables, etc, even a parameter reset on my MAC. Still same problem. Can you please help ? Thank You, Donny

Comments

  • Hello,
    I started having a similar problem yesterday, though I have not had the time to do much troubleshooting yet.
    The console was turned on and so was the PC (for at least two days), then suddenly: Every three or four seconds I get a loud POP. I thought it was the PC (Win10) sending garbage through the USB.
    Restarted the PC, and the console; it is the same.
    Unplugging the USB cable makes it stop immediateley, but as soon as the USB cable is plugged in, POP!
    It is not coming from Windows because it happens when the computer is showing the "HP Surestart", long before Windows is even loaded. I tried the other USB ports on the PC and it is the same.
    Anyone else have this problem?
    Any way to fix it?
    I will post anything new after I do more troubleshooting.
    Signature 22MTK

  • IceboundIcebound Posts: 1
    edited October 2019

    Same problem here. Lout pops from FX return channel. And my mac can't see this mixer as Interface anymore. Also headphones signal sometimes changing from stereo to mono.. No idea what to do. Seems like electronics in this fella is weakest part. Just can't use it any more. Maybe someday Soundcraft realise that they need to release firmware updates from time to time for their products

  • Did anyone solve that issue meanwhile? I have the same problem here for a couple of days now. Sometimes I am getting it to run after a couple of minutes. On other days it just does not work forever. I love that desk and my whole studio is dependent on that console. I have the pops, the FX are not selectable and the the Mixer does not appear in the Audio/MIDI setup. It's not a MAC issue. I have the same problem when running bootcamp and windows 7.
    In windows you can see that the device manager updates the devices view with each second pop. So the desk fails to init on a USB request I would think. That maybe results in FX init as well as the sample rate jumps between internal and external control. (just an idea)

    BTW.: I am the guy who did one of the most popular Soundcraft Signature MTK videos on youtube. I really love the console and are looking forward to get it to run again.

  • I just had the same problem with my Signature 22 MTK. I really hope to find a solution as my whole workflow revolves around this unit and i really don't have the pocket book for buying a new one.

    Anyone know anything about getting these repaired/serviced?
  • I've got exactly the same problem with my 12 MTK, I contacted Harman tech support with this message and they actually managed to get back pretty quickly about repairs, although I'm considering buying another console with some more inputs. I hope to repair my MTK sometime soon by myself or get some hints on what I can do to fix it.

    What I sent to support:
    "My Soundcraft Signature MTK 12 was working perfectly fine until around 4 months ago when it would disconnect from my computer when it started. I managed to quickly fix it by unplugging the mixer and plugging it back in when my PC was off, then it seemed to work again when my PC was turned on. I found that switching off my MTK at night was the cause, so I reluctantly kept it on overnight and I've had no problems for a while now.

    Until recently, the mixer started doing it again! Nothing seems to work in getting the interface to respond. The mixer portion still works fine, the only problem is that it won't connect to my PC via USB anymore. In my headphones, I can hear a clicking noise when the USB cable is connected and on the driver software I can see it connect and then disconnect, and then connect, and disconnect - over and over.

    When plugged in via USB the effects selection disappears and I can't select anything. If I'm doing it from a cold boot on my computer, the effects section will flash all whilst clicking through the outputs. When the USB cable is unplugged everything will go back to normal and I can select effects again.

    Things I have tried:
    Three different USB cables
    Many different USB ports
    Two other computers
    Several different plug sockets
    A different power cable
    Uninstalling and reinstalling the drivers

    Nothing works. The problem still persists. I've googled the problem and people have reported the exact same problem on their mixers around the same time. "

    I'm just really curious as to why so many units are experiencing the exact same problem at around the exact same time! It doesn't seem to matter if it's on Windows or Mac, something internally (I believe) has failed at the same time as everyone else's.

  • Hi, I am having the same problem. Has anyone got a fix? What is the reason for having this forum if no one answers with a fix. I am in contact with a Harmon tech and have an email address. I am going to try a couple of things tonight and if does not work I am to send pictures with the problem. After speaking with him today the clicking sound is the clock source and that it that the sample rate and KHZ should match.

  • Another one here with the same issue.... Is this a plague ? No one from Soundcraft to address this? I contacted my local distributor, I hope they can do the repair.
    Stuck in the middle of a projet :(

  • TommyVTommyV Posts: 2

    I Just was experiencing the same Issue after a year of use with the MTK signature 22, all of a sudden my macbook pro would not recognize the unit. I have a expensive $50 USB cable as well. I had a brand new still in the package USB cable from one of my printers that I thought I would try it and boom it instantly recognizes the SoundCraft MTK Signature 22. Im wondering if powering on and off may take a toll on these cables. Will see how long this one last

  • FrankyFranky Posts: 2
    edited January 13

    No, your issue is not the same as the one described in this topic. Changing the cable does not fix it.

    In my case, for those who wants to know, I have the unit repaired and they had to change a broken capacitor.

  • Franky, How much did the repair cost?? The symptoms with my unit are identical.

  • Same problem here. Any details on the repair?

    @Franky said:
    In my case, for those who wants to know, I have the unit repaired and they had to change a broken capacitor.

  • just this afternoon while recording with a band here in philippines soundcraft mtk22 suddenly stopped and unrecognized by my imac running high sierra. now after i let it off for 2-3 hours as it turns on i could tweak the eq knobs and its working, but the faders are not. there are no audio running through the groups 1-2/3-4/masterfader. i could not also use the pan. any help or idea from anyone who suffers this situation?
  • benganbengan Posts: 1

    Day before yesterday my mtk12 just got this problem. Poping sound every second and the driver (Linux) doesn't recognize anything on that USB-port. It's been working flawlessly for 4 years. Any official comments from Harman? I did my fault isolation and came to the conclusion that this sounds like charge and discharge of a capacitor. I'd like to (officially) know which capacitor I should replace. After some research on the net I found Gearslutz
    https://www.gearslutz.com/board/low-end-theory/1055612-soundcraft-signature-mtks-status-32.html and it's not exactly the same problem but I take it that it's in the same ballpark. So, to summarize: C111 and C113 (both 25V and 100uF) changed and everything works again.

  • AndrewBirdAndrewBird Posts: 1

    HeyHey! Just an update to this issue. Sorry I should've posted a year back.

    My MTK22 USB was powercycling up and down, popping and clicking. The FX panel was flickering on and off when USB was plugged in. Sometimes this would stabilise after 20mins or so but the analogue console stays beautifully alive, suggesting it's just a digital power issue.

    I actually had this issue on a previous digital/analogue items - the click of death!
    I called Harman to ask how much a new power supply would be and they were happy to supply.

    To solve:
    Simply look at the easily accessible power supply. Taking all the usual precautions, you'll need to unplug and remove it completely for the work.

    There's one ribbon cable to detach. Have a look at 112 and 113 capacitors - bets are they'll have expanded a little and the top won't be the usual flat top but it'll be a bump. Replace the two 25v/100uF capacitors, making sure that you line up the correct polarity. It should take less than an hour and you're good!

Sign In or Register to comment.